Bug 232297 - x11-servers/xorg-server: often freezes
Summary: x11-servers/xorg-server: often freezes
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-15 18:50 UTC by Piotr Kubaj
Modified: 2019-11-27 19:01 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
Xorg.0.log (74.97 KB, text/plain)
2018-10-16 13:14 UTC, Piotr Kubaj
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2018-10-15 18:50:26 UTC
I often have random freezes in X11. It happened with 11.2-RELEASE, I upgraded to 12.0-CURRENT, it still happens.
From /var/log/Xorg.0.log:
(EE)
(EE) [mi] EQ overflow continuing.  1000 events have been dropped.
(EE) [mi] No further overflow reports will be reported until the clog is cleared.
(EE)
(EE) Backtrace:
(EE) 0: /usr/local/bin/X (QueuePointerEvents+0x5b) [0x2a694b]
(EE) 1: /usr/local/bin/X (xf86PostMotionEvent+0x141) [0x2e9bf1]
(EE) unw_get_proc_name failed: no unwind info found [-10]
(EE) 2: /usr/local/lib/xorg/modules/input/mouse_drv.so (?+0x141) [0x98672dab1]
(EE) unw_get_proc_name failed: no unwind info found [-10]
(EE) 3: /usr/local/lib/xorg/modules/input/mouse_drv.so (?+0x141) [0x98672ad91]
(EE) unw_get_proc_name failed: no unwind info found [-10]
(EE) 4: /usr/local/lib/xorg/modules/input/mouse_drv.so (?+0x141) [0x98672a061]
(EE) 5: /usr/local/bin/X (xf86AddEnabledDevice+0x99) [0x2d90c9]
(EE) 6: /usr/local/bin/X (xf86InstallSIGIOHandler+0x357) [0x3007c7]
(EE) 7: /lib/libthr.so.3 (pthread_sigmask+0x536) [0x800b9d796]
(EE) 8: /lib/libthr.so.3 (pthread_getspecific+0xe0f) [0x800b9d61f]
(EE) 9: ? (?+0xe0f) [0x7fffffffffa2]
(EE) 10: /lib/libc.so.7 (_writev+0xa) [0x800d7f3c4]
(EE) 11: /lib/libthr.so.3 (pthread_suspend_all_np+0x18b6) [0x800b9c016]
(EE) 12: /usr/local/bin/X (os_move_fd+0x1fa9) [0x428ec9]
(EE) 13: /usr/local/bin/X (FlushAllOutput+0x2f9) [0x420b59]
(EE) 14: /usr/local/bin/X (WriteToClient+0x241) [0x420f61]
(EE) 15: /usr/local/bin/X (XkbSendStateNotify+0x193) [0x3c4a93]
(EE) 16: /usr/local/bin/X (AccessXFilterReleaseEvent+0x921) [0x3c7dc1]
(EE) 17: /usr/local/bin/X (LastEventTimeToggleResetAll+0x406) [0x297136]
(EE) 18: /usr/local/bin/X (ScreenRestructured+0xc38) [0x2988a8]
(EE) 19: /usr/local/bin/X (ScreenRestructured+0xa09) [0x298429]
(EE) 20: /usr/local/bin/X (ScreenRestructured+0x1274) [0x2994e4]
(EE) 21: /usr/local/bin/X (ProcAllowEvents+0xc8) [0x2988b8]
(EE) 22: /usr/local/bin/X (UpdateCurrentTimeIf+0x307) [0x286e37]
(EE) 23: /usr/local/bin/X (remove_fs_handlers+0x5a7) [0x291be7]
(EE) 24: /usr/local/bin/X (_start+0x94) [0x27a094]
(EE) 25: ? (?+0x94) [0x800498094]

I'm using Geforce GTX650Ti with x11/nvidia-driver.
Comment 1 Piotr Kubaj freebsd_committer 2018-10-15 18:50:57 UTC
It only happens with Nvidia GPU, it doesn't happen with Radeon or Intel on other computers.
Comment 2 Jan Beich freebsd_committer 2018-10-15 19:40:41 UTC
Did you boot via UEFI or legacy BIOS/CSM? Can you post Xorg.log? It's not clear what is at play. For one, sysmouse tends to be more buggy than using ums directly.

(In reply to Piotr Kubaj from comment #1)
On otherwise the same hardware? Have you tried downgrading nvidia-driver to previous version?
Comment 3 Piotr Kubaj freebsd_committer 2018-10-16 11:41:19 UTC
(In reply to Jan Beich from comment #2)
It uses BIOS/CSM. I could paste my Xorg.log, but it was overwritten, so next time it happens, I will put it here.

Radeon and Intel cards work, but on other hw, I didn't test other cards on this PC. I'm not sure how long it was since it started, it actually belongs to my parents...
Comment 4 Piotr Kubaj freebsd_committer 2018-10-16 11:42:17 UTC
(In reply to Piotr Kubaj from comment #3)
BTW, I can SSH in just fine and even restart X11, so if you wish, I can do some live debugging next time it happens (just need to know what to check).
Comment 5 Piotr Kubaj freebsd_committer 2018-10-16 13:14:04 UTC
Created attachment 198209 [details]
Xorg.0.log

It happened again. Here's my log.
Comment 6 Walter Schwarzenfeld freebsd_triage 2019-08-28 08:57:00 UTC
Does the problem still exists?
Comment 7 Piotr Kubaj freebsd_committer 2019-08-28 09:20:08 UTC
(In reply to Walter Schwarzenfeld from comment #6)
Yes.
Comment 9 Piotr Kubaj freebsd_committer 2019-11-27 19:01:48 UTC
It turns out the issue was caused by KDE. I'm not sure why and I can't investigate it because the PC is a couple hundred kilometers away and used by my parents. It seems stable with XFCE though (or anything else). It's not Xorg's or Nvidia's issue because the problem was still happening after replacing with Radeon.