Bug 232376 - net/remmina remmina-1.2.31.4 depends on shared library: libssh_threads.so - not found
Summary: net/remmina remmina-1.2.31.4 depends on shared library: libssh_threads.so - n...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ben Woods
URL:
Keywords: regression
Depends on:
Blocks: 232344
  Show dependency treegraph
 
Reported: 2018-10-18 09:05 UTC by Graham Perrin
Modified: 2018-10-27 05:04 UTC (History)
1 user (show)

See Also:
woodsb02: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2018-10-18 09:05:30 UTC
# tail -n 16 /usr/local/poudriere/data/logs/bulk/current-default/2018-10-18_09h47m19s/logs/remmina-1.2.31.4.log 
===>   Returning to build of remmina-1.2.31.4
===>   remmina-1.2.31.4 depends on shared library: libgcrypt.so - found (/usr/local/lib/libgcrypt.so)
===>   remmina-1.2.31.4 depends on shared library: libssh_threads.so - not found
===>   Installing existing package /packages/All/libssh-0.8.4.txz
[current-default-job-01] Installing libssh-0.8.4...
[current-default-job-01] Extracting libssh-0.8.4: .......... done
===>   remmina-1.2.31.4 depends on shared library: libssh_threads.so - not found
*** Error code 1

Stop.
make: stopped in /usr/ports/net/remmina
=>> Cleaning up wrkdir
===>  Cleaning for remmina-1.2.31.4
build of net/remmina | remmina-1.2.31.4 ended at Thu Oct 18 09:49:37 BST 2018
build time: 00:01:21
!!! build failure encountered !!!
# 

----

# date ; uname -v
Thu 18 Oct 2018 10:04:37 BST
FreeBSD 12.0-ALPHA9 r339356 GENERIC-NODEBUG 
#
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-10-19 21:07:41 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1618707

==> 
Seems to be a missing symlink.
/lib64/libssh_threads.so.4 -> libssh.so.4.5.1
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-10-19 21:39:38 UTC
If I am right, needs only to change in the Makefile:

SSH_LIB_DEPENDS=        libssh_threads.so:security/libssh
to
SSH_LIB_DEPENDS=        libssh2.so:security/libssh2
(builds and installs fine with this change, I don't tested functionality).
Comment 3 commit-hook freebsd_committer 2018-10-27 02:27:34 UTC
A commit references this bug:

Author: woodsb02
Date: Sat Oct 27 02:27:20 UTC 2018
New revision: 483100
URL: https://svnweb.freebsd.org/changeset/ports/483100

Log:
  net/remmina: Fix build with security/libssh 0.8 branch

  libssh 0.8.x no longer installs libssh_threads.so [1], [2], [3].
  The upstream remmina code has been updated to accomodate this [4].
  Therefore the remmina port Makefiles simply need to be updated to depend
  on libssh.so instead of libssh_threads.so.

   [1] https://git.libssh.org/projects/libssh.git/commit/?id=83b43443e51b5db06184750fb874e1e8d7ece95a
   [2] https://git.libssh.org/projects/libssh.git/commit/?id=8425dce7b27d9e6868735b7ca6dc4e50094af9fa
   [3] https://git.libssh.org/projects/libssh.git/commit/?id=d0f3cdfa10436d2108e0b75aad53ce976db3e546
   [4] https://github.com/FreeRDP/Remmina/commit/8d654eca784d5e1b2c6e853b7beb7ad3d8322290#diff-b467acb9761e344e80ab07b9e7325b66

  PR:		232376
  Reported by:	Graham Perrin <grahamperrin@gmail.com>

Changes:
  head/net/remmina/Makefile
  head/net/remmina-plugin-nx/Makefile
Comment 4 Ben Woods freebsd_committer 2018-10-27 02:29:23 UTC
Fix committed - thanks for the report.
Note that this doesn't need to be merged to the 2018Q4 ports quarterly branch, as that is still using the libssh 0.7.x branch.
Comment 5 Graham Perrin 2018-10-27 05:04:21 UTC
Thanks for the fix!