Bug 232460 - net-mgmt/ocsinventory-server and net-mgmt/ocsinventory-ocsreports fixes
Summary: net-mgmt/ocsinventory-server and net-mgmt/ocsinventory-ocsreports fixes
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-19 21:20 UTC by geoffroy desvernay
Modified: 2019-04-09 21:44 UTC (History)
1 user (show)

See Also:


Attachments
svn diff net-mgmt/ocsinventory-server (1.22 KB, patch)
2018-10-19 21:20 UTC, geoffroy desvernay
dgeo: maintainer-approval+
Details | Diff
svn diff net-mgmt/ocsinventory-ocsreports (2.52 KB, patch)
2018-10-19 21:21 UTC, geoffroy desvernay
dgeo: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description geoffroy desvernay 2018-10-19 21:20:46 UTC
Created attachment 198381 [details]
svn diff net-mgmt/ocsinventory-server

* Some bugs stayed in templates files
* Rename ocsreport's ETCDIR to get server and ocsreports live in same ETCDIR (moves only apache config templates, no break on existing setups)
* setup.pl script would need some work too, but no these ones should be a better start - document it
* add missing lang/p5-Switch dependency
Comment 1 geoffroy desvernay 2018-10-19 21:21:24 UTC
Created attachment 198382 [details]
svn diff net-mgmt/ocsinventory-ocsreports
Comment 2 Kurt Jaeger freebsd_committer 2019-02-10 18:26:09 UTC
testbuilds@work
Comment 3 geoffroy desvernay 2019-04-08 15:19:42 UTC
@Kurt did it worked for you ?
Comment 4 Kurt Jaeger freebsd_committer 2019-04-08 18:07:34 UTC
thanks for reminding me, I'll re-do the testbuild. It has been too long,
I do not remember the results.
Comment 5 Kurt Jaeger freebsd_committer 2019-04-09 19:26:55 UTC
I have problems with the builds for ocsreports, because of this:

===>   ocsinventory-ocsreports-2.5_1 depends on file: /usr/local/lib/php/20180731/mysqli.so - not found
===>   Installing existing package /packages/All/php73-mysqli-7.3.4.txz
[cur-default] Installing php73-mysqli-7.3.4...
[cur-default] Extracting php73-mysqli-7.3.4: .......... done
===>   ocsinventory-ocsreports-2.5_1 depends on file: /usr/local/lib/php/20180731/mysqli.so - not found

This happens because I have

     ZTS=on: Force Zend Thread Safety (ZTS) build

for lang/php73, and this installs

/usr/local/lib/php/20180731-zts/mysqli.so

but the check is for

/usr/local/lib/php/20180731/mysqli.so

I have not yet found a solution for this (but I did spend much time on it).
Comment 6 geoffroy desvernay 2019-04-09 21:37:23 UTC
This doesn't seems related to this particular port, but to ports's php.mk, doesn't it ?

If I get it well, using ZTS does break all ports using USE_PHP. This should be worked on in another PR I think…

Do I miss something here ? (I wouldn't be surprised to :)
Comment 7 geoffroy desvernay 2019-04-09 21:44:03 UTC
It seems that PHP_EXT_DIR is not correctly determined in Mk/Uses/php.mk ?

As if "php-config --extension-dir" returned a bad path ?

Sorry I don't have a ZTS version here to check this quickly…