Bug 232475 - www/falkon: never ending loadings of Web content
Summary: www/falkon: never ending loadings of Web content
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-20 16:18 UTC by Lorenzo Salvadore
Modified: 2018-11-24 11:41 UTC (History)
2 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments
suggested pkg-message for www/falkon (182 bytes, text/plain)
2018-10-20 16:18 UTC, Lorenzo Salvadore
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lorenzo Salvadore 2018-10-20 16:18:32 UTC
Created attachment 198401 [details]
suggested pkg-message for www/falkon

Using falkon on FreeBSD-11.2 loading Web content sometimes fails with pages that never finish their loading. The issue is reproducible by just visiting pages at random and more complex pages seem to be more likely to cause the loading problem.

I read in www/firefox/pkg-message that on FreeBSD versions  < 11.3 there is a known bug concerning the base system (bug #181741)  for which a workaround exists: setting net.local.stream.recvspace to 16384 through sysctl. I tried the workaround and it seems to fix falkon too: I suggest creating a www/falkon/pkg-message file with a similar message.

You can find a possibile www/falkon/pkg-message suggestion in the attachment: it is the same text of www/firefox/pkg-message (only the relevant part), except that I changed the prompt "$" with "#" (this should suggest that sysctl must be run as root and not as normal user).

To confirm that the issue is probably related to the FreeBSD system I can add that I used falkon before with the same hardware on Linux and I never had this problem.
Comment 1 Tobias C. Berner freebsd_committer 2018-11-24 08:45:53 UTC
(In reply to Lorenzo Salvadore from comment #0)
Hi Lorenzo

Is this still an issue (I think the fix has been mfc-ed). If so, I'll add it :)


mfg Tobias
Comment 2 Lorenzo Salvadore 2018-11-24 09:34:24 UTC
(In reply to Tobias C. Berner from comment #1)

Yes, it is still an issue: I have just tested (on 11.2-RELEASE amd64).

If you thought the bug was fixed because bug #181741 is, observe that it was closed in date 2018-08-17, while I reported the bug in date 2018-10-20.
Comment 3 commit-hook freebsd_committer 2018-11-24 11:40:34 UTC
A commit references this bug:

Author: tcberner
Date: Sat Nov 24 11:39:38 UTC 2018
New revision: 485758
URL: https://svnweb.freebsd.org/changeset/ports/485758

Log:
  www/falkon: add pkg-message to work around infinite loading on FreeBSD 11

  PR:		232475
  Submitted by:	Lorenzo Salvadore <phascolarctos@protonmail.ch>

Changes:
  head/www/falkon/pkg-message
Comment 4 Tobias C. Berner freebsd_committer 2018-11-24 11:41:14 UTC
Committed. Thanks.