Bug 232499 - x11-drivers/xf86-video-ati: "failed to add FB for modeset" "Failed to set mode on CRTC 0" "Failed to enable any CRTC"
Summary: x11-drivers/xf86-video-ati: "failed to add FB for modeset" "Failed to set mod...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-21 07:20 UTC by Martin Birgmeier
Modified: 2018-11-03 10:05 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
Xorg.0.log (22.79 KB, text/plain)
2018-10-21 07:20 UTC, Martin Birgmeier
no flags Details
xorg.conf (3.16 KB, text/plain)
2018-10-21 07:20 UTC, Martin Birgmeier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2018-10-21 07:20:11 UTC
Created attachment 198428 [details]
Xorg.0.log

When starting X, the screen goes blank (power save). The following messages appear in Xorg.0.log:

[   107.089] failed to add FB for modeset
[   107.089] (WW) RADEON(0): Failed to set mode on CRTC 0
[   107.092] (EE) RADEON(0): Failed to enable any CRTC

xorg.conf and Xorg.0.log are attached.
Comment 1 Martin Birgmeier 2018-10-21 07:20:45 UTC
Created attachment 198429 [details]
xorg.conf
Comment 2 Niclas Zeising freebsd_committer 2018-10-24 15:27:14 UTC
Hi!
Can you provide some more information about your system?  What version and architecture of FreeBSD are you using, what's your graphics card model?

If you are on FreeBSD 11.2 or later on amd64, can you please try to install graphics/drm-kmod, follow the instructions to load the kernel module, and then try again?

If that fails, can you try x11-drivers/xf86-video-ati-legacy ?

Thanks!
Comment 3 Martin Birgmeier 2018-10-25 17:01:07 UTC
Hi Niclas,

Thank you for your feedback.

The system hardware is based on an AMD 890GX chipset with built-in graphics; according to Wikipedia, it is a Radeon HD 4290. In /var/log/Xorg.0.log it is identified as

[  2026.863] (--) RADEON(0): Chipset: "ATI Radeon HD 4290" (ChipID = 0x9714)

The OS is FreeBSD 11.2. uname -a gives

FreeBSD hal.xyzzy 11.2-RELEASE-p4 FreeBSD 11.2-RELEASE-p4 #3 r338999M: Fri Sep 28 18:33:15 CEST 2018     root@v908.xyzzy:/.../hal/z/OBJ/FreeBSD/amd64/releng/11.2/sys/XYZZY_SMP  amd64

I first tried to install graphics/drm-kmod, but it requires graphics/gpu-firmware-kmod with 492 kernel modules, so I instead opted to go with x11-drivers/xf86-video-ati-legacy.

This works.

I'll close this ticket.
Comment 4 gja822 2018-11-03 05:44:36 UTC
Just happen to run into the same bug after some updated ports and reboot. No occurence in UPDATING in the ports, worked OK before. Chipset Radeon graphics also.
Comment 5 Niclas Zeising freebsd_committer 2018-11-03 10:03:58 UTC
(In reply to gja822 from comment #4)

Hi!
Did you try either installing graphics/drm-kmod and follow the instructions to load that module, or replacing xf86-video-ati with xf86-video-ati-legacy?
Comment 6 Niclas Zeising freebsd_committer 2018-11-03 10:05:50 UTC
(In reply to Martin Birgmeier from comment #3)

graphics/gpu-firmware-kmod contains firmware for use with the various graphics adapters we support.  There's a lot of firmware, becasue there's a lot of grapics adapters.  Note that there are also firmware kmods in the FreeBSD base system, which you are using when using the driver from base.

graphics/gpu-firmware-kmod contains more firmware than what's in base, since it supports more graphics hardware.