Bug 232528 - emulators/virtualbox-ose: VNC doesn't work after upgrading to 5.2.20
Summary: emulators/virtualbox-ose: VNC doesn't work after upgrading to 5.2.20
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jung-uk Kim
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-22 14:54 UTC by Volodymyr Kostyrko
Modified: 2018-11-29 21:16 UTC (History)
10 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments
patch (751 bytes, text/plain)
2018-11-29 05:31 UTC, Dutchman01
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volodymyr Kostyrko 2018-10-22 14:54:54 UTC
Hello.

After upgrading to 5.2.20 remote VNC connection succeeds but only shows black windows of default size regardless of what happens on VM. VM works perfectly, there's just no image on VNC.

Tapping keys over VNC window makes them go to vm correctly.

Thanks in advance.
Comment 1 Dutchman01 2018-10-26 15:06:35 UTC
I have the same problem, noVNC and or tightVNC shows only black screens.
Comment 2 arinci 2018-10-26 15:22:40 UTC
Same problem here!
Comment 3 Daisuke Ban 2018-10-28 15:14:31 UTC
Same problem occurs on my FreeBSD box (11.2-RELEASE-p4 / amd64)
Client: UltraVNC (on Windows10) and Chicken of the VNC (MacOS)
Comment 4 Nikita Druba 2018-10-29 10:22:04 UTC
I confirm, FreeBSD 11.1 and 11.2.
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-10-29 13:52:46 UTC
If you have set 3D Acceleration, try to disable it.
Comment 6 Volodymyr Kostyrko 2018-10-29 14:03:28 UTC
Was disabled. 2D enabled.
Comment 7 Dutchman01 2018-10-29 15:55:16 UTC
2D/3D enabled/Disable does not help at all to get output visible at all.
For me it's clear that 5.2.20 changed something to break this. 5.2.18 is fine.

11.2-RELEASE-p4 / amd64 for me too
Comment 8 G. Paul Ziemba 2018-10-29 20:12:30 UTC
Same problem here. Host 12.0-BETA1 r339549, port virtualbox-ose-5.2.20.

At least I know I am not the only one experiencing this issue.
Comment 9 Dutchman01 2018-10-31 23:17:04 UTC
FYI, there's a ticket open in the virtualbox site as well: https://www.virtualbox.org/ticket/18072
Comment 10 Aleksandr 2018-11-10 10:10:24 UTC
I confirm, FreeBSD 12 beta 2 (amd64)
Comment 11 Dutchman01 2018-11-11 09:38:08 UTC
Just tested with vbox 5.2.22 again on 11.2 p4 x64.
Same problem occurs, only black vnc screens.
Comment 12 VVD 2018-11-21 17:23:16 UTC
Same here: 5.2.18 work fine, 5.2.20, 5.2.22 - black screen 640x480, but keyboard work.
Comment 13 Dutchman01 2018-11-29 05:31:51 UTC
Created attachment 199654 [details]
patch

after patch https://www.virtualbox.org/attachment/ticket/18153/vnc_fix.patch

novnc output working again on 5.2.20 and 5.2.22 versions.
Comment 14 VVD 2018-11-29 12:54:42 UTC
(In reply to Dutchman01 from comment #13)
This patch work for me.
Comment 15 G. Paul Ziemba 2018-11-29 18:11:42 UTC
(In reply to Dutchman01 from comment #13)
Works for me on 5.2.20. Thanks!
Comment 16 Jung-uk Kim freebsd_committer 2018-11-29 18:36:28 UTC
I'll take it.
Comment 17 commit-hook freebsd_committer 2018-11-29 21:10:26 UTC
A commit references this bug:

Author: jkim
Date: Thu Nov 29 21:09:26 UTC 2018
New revision: 486206
URL: https://svnweb.freebsd.org/changeset/ports/486206

Log:
  Fix a VNC regression since 5.2.20.

  PR:		232528
  Obtained from:	VirtualBox Ticket #18153

Changes:
  head/emulators/virtualbox-ose/Makefile
  head/emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp
Comment 18 Jung-uk Kim freebsd_committer 2018-11-29 21:16:54 UTC
Committed, thanks!