Bug 232535 - lang/ecl: installation failure with THREADS enabled
Summary: lang/ecl: installation failure with THREADS enabled
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jimmy Olgeni
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-22 16:06 UTC by Lorenzo Salvadore
Modified: 2019-08-16 08:01 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (olgeni)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lorenzo Salvadore 2018-10-22 16:06:25 UTC
I believe this port is affected by a bug similar to bug #222310 (it concerns sbcl, another lisp implementation).

As for sbcl, the installation fails for me with THREADS enabled and works with it disabled (see comment 5 of sbcl's bug).

In the ecl case, pkg-static fails during the registration of the installation: many files under the include/ecl/atomic-ops directory are missing, as well as include/ecl/atomic-ops.h
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-08-16 01:01:13 UTC
Is this still a problem, or could this closed (same cause as in bug #222310 ?).
Comment 2 Lorenzo Salvadore 2019-08-16 08:01:18 UTC
(In reply to Walter Schwarzenfeld from comment #1)

 I confirm that the issue is still there, but I guess it has the same cause than bug #222310 and then that it can be safely closed.