Bug 232539 - www/redmine: Does not work with POSTGRESQL option enabled
Summary: www/redmine: Does not work with POSTGRESQL option enabled
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords: easy, needs-qa
Depends on:
Blocks:
 
Reported: 2018-10-22 17:50 UTC by cedric
Modified: 2018-12-09 20:03 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (ruby)
koobs: merge-quarterly?


Attachments
Patch (799 bytes, patch)
2018-10-29 13:13 UTC, cedric
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description cedric 2018-10-22 17:50:09 UTC
Following patch is needed, or redmine will use an unsupported rubygem-pg.

Index: Makefile
===================================================================
--- Makefile    (revision 476463)
+++ Makefile    (working copy)
@@ -54,7 +54,7 @@
 NO_OPTIONS_SORT=       yes
 
 MYSQL_RUN_DEPENDS=     rubygem-mysql2>=0.4.6:databases/rubygem-mysql2
-POSTGRESQL_RUN_DEPENDS=        rubygem-pg>=0.18.1:databases/rubygem-pg
+POSTGRESQL_RUN_DEPENDS=        rubygem-pg018>=0.18.1:databases/rubygem-pg018
 MARKDOWN_RUN_DEPENDS=  rubygem-redcarpet>=3.4.0:textproc/rubygem-redcarpet
 RMAGIC_RUN_DEPENDS=    rubygem-rmagick>=2.14.0:graphics/rubygem-rmagick
 THIN_RUN_DEPENDS=      rubygem-thin>=1.6.2:www/rubygem-thin
Index: files/pg.rb
===================================================================
--- files/pg.rb (revision 476463)
+++ files/pg.rb (working copy)
@@ -1 +1 @@
-gem "pg", ">= 0.18.1"
+gem "pg", "~> 0.18.1"
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2018-10-23 07:18:17 UTC
Thank you Cedric. If you could attach your patch from comment 0 as an attachment that would be appreciated
Comment 2 cedric 2018-10-29 13:13:25 UTC
Created attachment 198735 [details]
Patch
Comment 3 cedric 2018-10-31 08:55:26 UTC
Note: I know nothing about ruby, but I've found that the change in files/pg.rb is needed, because it needs to match the specifications in the Gemfile.

Before that change, the following message would show up:

config/log/thin.log:You specified: pg (~> 0.18.1) and pg (>= 0.18.1). Bundler cannot continue.
Comment 4 cedric 2018-11-08 18:17:03 UTC
Ping
Comment 5 cedric 2018-11-21 12:17:56 UTC
Ping
Comment 6 Steve Wills freebsd_committer 2018-12-09 06:55:38 UTC
(In reply to cedric from comment #5)
Sorry for the delay, will try to look at this in the next few days.
Comment 7 commit-hook freebsd_committer 2018-12-09 20:03:15 UTC
A commit references this bug:

Author: swills
Date: Sun Dec  9 20:02:32 UTC 2018
New revision: 487077
URL: https://svnweb.freebsd.org/changeset/ports/487077

Log:
  www/redmine: Fix PostgreSQL option

  PR:		232539
  Submitted by:	cedric <cedric@precidata.com>

Changes:
  head/www/redmine/Makefile
  head/www/redmine/files/pg.rb
Comment 8 Steve Wills freebsd_committer 2018-12-09 20:03:43 UTC
Committed, thanks!