Bug 232568 - multimedia/librtmp: fails to build on 11.2 with DEFAULT_VERSIONS+=ssl=base
Summary: multimedia/librtmp: fails to build on 11.2 with DEFAULT_VERSIONS+=ssl=base
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Sato
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-23 19:30 UTC by Martin Birgmeier
Modified: 2018-10-23 22:07 UTC (History)
1 user (show)

See Also:
woodsb02: maintainer-feedback-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2018-10-23 19:30:04 UTC
Scenario:
- Running 11.2
- Have "DEFAULT_VERSIONS+=ssl=base" in /etc/make.conf
- Rebuilding multimedia/librtmp
- Later on, rebuilding math/libqalculate

Result:
- Build of librtmp-2.4.20151223_1 succeeds
- librtmp contains undefined symbols which lead to linker errors in programs using it
- Build of libqalculate-2.6.1_1 fails with

/usr/local/lib/librtmp.so.1: undefined reference to `DH_get0_pqg'
/usr/local/lib/librtmp.so.1: undefined reference to `DH_set_length'
/usr/local/lib/librtmp.so.1: undefined reference to `DH_get0_key'
/usr/local/lib/librtmp.so.1: undefined reference to `HMAC_CTX_free'
/usr/local/lib/librtmp.so.1: undefined reference to `DH_set0_key'
/usr/local/lib/librtmp.so.1: undefined reference to `HMAC_CTX_new'

Fix:
- The openssl-1.1.1 patch must only be applied if a corresponding openssl version is indeed installed
Comment 1 Martin Birgmeier 2018-10-23 19:35:51 UTC
Note: librtmp inclusion in libqalculate via ftp/curl
Comment 2 Ben Woods freebsd_committer 2018-10-23 22:07:40 UTC
I believe this was caused by my commit r482833 for PR231940.
This commit has now been reverted in r482870, so this bug can be closed.