Bug 232637 - Duplicate line in ffmpeg/Makefile [PATCH]
Summary: Duplicate line in ffmpeg/Makefile [PATCH]
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords:
: 232636 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-24 16:21 UTC by ktullavik
Modified: 2018-10-28 17:52 UTC (History)
0 users

See Also:


Attachments
Remove duplicate line. (437 bytes, patch)
2018-10-24 16:22 UTC, ktullavik
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ktullavik 2018-10-24 16:21:34 UTC
The line
DATADIR=       ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
occurs twice and consecutively in multimedia/ffmpeg/Makefile.
Comment 1 ktullavik 2018-10-24 16:22:27 UTC
Created attachment 198578 [details]
Remove duplicate line.
Comment 2 commit-hook freebsd_committer 2018-10-24 18:08:03 UTC
A commit references this bug:

Author: tobik
Date: Wed Oct 24 18:07:43 UTC 2018
New revision: 482928
URL: https://svnweb.freebsd.org/changeset/ports/482928

Log:
  multimedia/ffmpeg: Do not set DATADIR twice

  PR:		232637

Changes:
  head/multimedia/ffmpeg/Makefile
Comment 3 Tobias Kortkamp freebsd_committer 2018-10-24 18:08:52 UTC
*** Bug 232636 has been marked as a duplicate of this bug. ***
Comment 4 commit-hook freebsd_committer 2018-10-24 18:11:10 UTC
A commit references this bug:

Author: tobik
Date: Wed Oct 24 18:10:17 UTC 2018
New revision: 482930
URL: https://svnweb.freebsd.org/changeset/ports/482930

Log:
  MFH: r482928

  multimedia/ffmpeg: Do not set DATADIR twice

  PR:		232637

  Approved by:	ports-secteam blanket (avoid potential merge conflict)

Changes:
_U  branches/2018Q4/
  branches/2018Q4/multimedia/ffmpeg/Makefile
Comment 5 commit-hook freebsd_committer 2018-10-28 17:52:47 UTC
A commit references this bug:

Author: riggs
Date: Sun Oct 28 17:52:05 UTC 2018
New revision: 483320
URL: https://svnweb.freebsd.org/changeset/ports/483320

Log:
  MFH: r482030 r482658 r482928 r483316

  Enable XCB option by default

  Rationale:
  - XCB offers a comfortable screen capturing function via
    ffmpeg -f x11grab
  - In the default package libxcb is installed as a dependency
    of libX11 anyway, hence no need to disable it for ffmpeg
    specifically

  PR:		231215
  Reported by:	vermaden@interia.pl

  multimedia/ffmpeg: unbreak ALSA=off after r468844

  https://ffmpeg.org/pipermail/ffmpeg-devel/2018-September/234516.html

  PR:		232498

  multimedia/ffmpeg: Do not set DATADIR twice

  PR:		232637

  Unbreak build on 12-BETA after OpenSSL 1.1.1 import into base

  PR:		232707
  Submitted by:	fluffy

  Approved by:	ports-secteam (riggs)

Changes:
_U  branches/2018Q4/
  branches/2018Q4/multimedia/ffmpeg/Makefile
  branches/2018Q4/multimedia/ffmpeg/files/patch-configure