Bug 232649 - multimedia/librtmp: (OpenSSL 1.1.1?) error: field has incomplete type 'HMAC_CTX'
Summary: multimedia/librtmp: (OpenSSL 1.1.1?) error: field has incomplete type 'HMAC_CTX'
Status: Closed DUPLICATE of bug 231940
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Hiroki Sato
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-24 17:24 UTC by O. Hartmann
Modified: 2018-10-24 18:13 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-10-24 17:24:22 UTC
On recent CURRENT (FreeBSD 13.0-CURRENT #714 r339685: Wed Oct 24 18:04:08 CEST 2018 amd64) with ports tree at r482913, building port multimedia/librtmp fails withthe error shown below.


[...]
--- parseurl.o ---
cc  -O2 -pipe  -I/usr/include -fstack-protector -fno-strict-aliasing  -DRTMPDUMP_VERSION=\"v2.4\" -DUSE_OPENSSL  -fPIC -c parseurl.c -o parseurl.o
--- hashswf.o ---
hashswf.c:292:12: error: field has incomplete type 'HMAC_CTX' (aka 'struct hmac_ctx_st')
  HMAC_CTX ctx;
Comment 1 Tobias Kortkamp freebsd_committer 2018-10-24 18:13:47 UTC

*** This bug has been marked as a duplicate of bug 231940 ***