Bug 232701 - www/firefox: Multiprocess Windows support is broken after upgrade to 63.0
Summary: www/firefox: Multiprocess Windows support is broken after upgrade to 63.0
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Walter Schwarzenfeld
URL:
Keywords:
: 232875 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-26 09:41 UTC by Ivan
Modified: 2019-08-08 00:42 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments
build log (202.87 KB, application/gzip)
2018-10-26 09:41 UTC, Ivan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan 2018-10-26 09:41:30 UTC
Created attachment 198648 [details]
build log

Tabs are not displaying any content (tab crashed message), console is filled with cannot to send/recv messages.

Workaround is to change browser.tabs.remote.autostart to false. Problem is not existing on FF 62
Comment 1 Jan Beich freebsd_committer 2018-10-26 10:49:51 UTC
Did you read pkg-message note from ports r480744?
Comment 2 Ivan 2018-10-26 20:37:08 UTC
(In reply to Jan Beich from comment #1)
Yes, I set net.local.stream.recvspace=16384 just after upgrade.
And, having the same notice, ESR version of FF works.
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-10-26 21:40:36 UTC
I have some random freezes since 63.0.
Comment 4 Jan Beich freebsd_committer 2018-10-26 22:03:07 UTC
(In reply to w.schwarzenfeld from comment #3)
> I have some random freezes since 63.0.

On FreeBSD 11.2? Only when Multiprocess Windows (aka Electrolysis) are enabled? Please, describe the freezes in more detail.
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-10-26 22:48:24 UTC
Firefox "forgot" some settings after the last updates. After your last comment, I enable electrolyses again. (browser.tabs.remote.force-enable=true I think).
So I have to wait one or two days if this helps.
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-10-28 02:34:55 UTC
Firefox freezes again. But I can tell you no reason, or further information (I don't know what's happen).
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-10-28 02:59:13 UTC
Sometimes it crashes and coredumps. Sometimes I could destroy the window. But I still can see
four threads in ps auxwww. Sometimes I could kill this threads. Sometimes not and have to log out
or reboot. 
I have only for addons (adblock, noscript, colorfultab and video downloadhelper). Don't think this
addon causes this. I also think it is not video related.
Comment 8 Jan Beich freebsd_committer 2018-10-28 08:51:14 UTC
Try to get a backtrace from the crashes after building WITH_DEBUG=1. Maybe the issue is not IPC-related. Anyway, I need more data (e.g., "me too" with details) or steps to reproduce.

Workaround for bug 181741 is also undertested. Maybe try applying the commit MFC'd to /stable/11 locally.
Comment 9 Walter Schwarzenfeld freebsd_triage 2018-10-30 22:11:00 UTC
Seems it was trivial. "Cleaned up" my profile and for the moment it seems it is ok.
Comment 10 Jan Beich freebsd_committer 2018-11-06 13:20:27 UTC
*** Bug 232875 has been marked as a duplicate of this bug. ***
Comment 11 Jan Beich freebsd_committer 2018-12-10 20:17:20 UTC
Did anything change after Firefox 64 update?
Comment 12 Ivan 2018-12-11 18:44:48 UTC
Not observing this on 12.0-RC3. Probably, we can close this one.