Bug 232709 - fix overspecification of BROKEN on sysutils/cfengine3*
Summary: fix overspecification of BROKEN on sysutils/cfengine3*
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Cy Schubert
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-26 12:33 UTC by Mark Linimon
Modified: 2018-11-02 16:11 UTC (History)
0 users

See Also:


Attachments
patch to sysutils/cfengine3* (8.18 KB, patch)
2018-10-26 12:33 UTC, Mark Linimon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2018-10-26 12:33:32 UTC
Created attachment 198655 [details]
patch to sysutils/cfengine3*

Adding BROKEN_FreeBSD_12 overspecfied the brokenness.  If like me you are still on e.g. 12-ALPHA4 these ports still build.
Comment 1 Cy Schubert freebsd_committer 2018-10-26 12:46:46 UTC
They only build if ports/security/openssl is installed. Installing  ports/security/openssl breaks other ports. You will need to update to the latest cfengine port, either cfengine or cfengine312. Both of them do support openssl111.
Comment 2 Cy Schubert freebsd_committer 2018-10-26 12:56:24 UTC
These ports do not build for me, as do I receive build failure emails for 12-alpha.
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2018-10-26 14:11:24 UTC
(In reply to Cy Schubert from comment #2)

They do build on 12.0-ALPHA6 FreeBSD 12.0-ALPHA6 #1 r338678M, which is in the range I specified.  (I do have the logs).  IIUC the package build machines have already been updated past that.
Comment 4 commit-hook freebsd_committer 2018-10-31 05:11:37 UTC
A commit references this bug:

Author: cy
Date: Wed Oct 31 05:10:52 UTC 2018
New revision: 483549
URL: https://svnweb.freebsd.org/changeset/ports/483549

Log:
  Rather than flag cfengine ports that do not support openssl111
  unconditionally BROKEN under FreeBSD 12 & 13, only flag BROKEN
  when security/openssl is not installed on systems after
  openssl111 was committed to 12-CURRENT.

  PR:		232709
  Reported by:	linimon

Changes:
  head/sysutils/cfengine310/Makefile
  head/sysutils/cfengine311/Makefile
  head/sysutils/cfengine32/Makefile
  head/sysutils/cfengine33/Makefile
  head/sysutils/cfengine34/Makefile
  head/sysutils/cfengine35/Makefile
  head/sysutils/cfengine36/Makefile
  head/sysutils/cfengine37/Makefile
  head/sysutils/cfengine38/Makefile
  head/sysutils/cfengine39/Makefile