Bug 232811 - ports-mgmt/pkg: 'pkg upgrade' can fail with exit status 0
Summary: ports-mgmt/pkg: 'pkg upgrade' can fail with exit status 0
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-pkg mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-30 10:39 UTC by david
Modified: 2018-10-30 10:39 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (pkg)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description david 2018-10-30 10:39:47 UTC
As shown in the typescript in <http://www.catwhisker.org/~david/FreeBSD/ports/>, 'pkg upgrade' can encounter an error that prevents it from actually upgrading anything, but then terminate with an exit status of 0.

Salient excerpts from <http://www.catwhisker.org/~david/FreeBSD/ports/typescript_pkg_upgrade>:

Script started on Sun Oct 28 05:33:41 2018
...

Checking integrity... done (0 conflicting)
The following 47 package(s) will be affected (of 0 checked):

Installed packages to be REMOVED:
	webkit-gtk2-2.4.11_17
	webkit2-gtk3-2.20.5
	gvfs-1.30.4
	gnome-online-accounts-3.28.0
	libgdata-0.17.9

Installed packages to be UPGRADED:
	tmux: 2.7 -> 2.8
	tesseract: 3.05.02_2 -> 3.05.02_3
	sqlite3: 3.25.1 -> 3.25.1_1
	spidermonkey52: 52.8.0_1 -> 52.8.0_2
	qtchooser: 39 -> 66
	qt5-core: 5.11.2 -> 5.11.2_1
	python36: 3.6.6_1 -> 3.6.7
	py27-openssl: 17.5.0_1 -> 18.0.0
	py27-libxml2: 2.9.7 -> 2.9.7_1
	py27-gimp: 2.8.22_1 -> 2.10.6_1
	portmaster: 3.19_15 -> 3.19_18
	pkgconf: 1.5.3,1 -> 1.5.4,1
	pciids: 20180921 -> 20181027
	nss: 3.39 -> 3.40
	netpbm: 10.83.02 -> 10.84.02
	net-snmp: 5.7.3_18 -> 5.7.3_19
	neon: 0.30.2_3 -> 0.30.2_4
	mesa-dri: 18.1.9 -> 18.1.9_1
	llvm60: 6.0.1_2 -> 6.0.1_3
	linux-c6: 6.9_1 -> 6.10_1
	libdvdcss: 1.4.1 -> 1.4.2
	icu: 62.1_2,1 -> 63.1,1
	help2man: 1.47.7 -> 1.47.8
	harfbuzz-icu: 2.0.0 -> 2.0.2_1
	harfbuzz: 2.0.0 -> 2.0.2
	gtk-doc: 1.28 -> 1.29
	gpgme: 1.11.1 -> 1.12.0
	glib: 2.56.1_1,1 -> 2.56.1_2,1
	gimp-app: 2.8.22_1,1 -> 2.10.6_1,1
	gimp: 2.8.22,2 -> 2.10.6,2
	freeglut: 3.0.0_1 -> 3.0.0_2
	firefox: 62.0.3,1 -> 63.0_3,1
	ffmpeg: 4.0.2_5,1 -> 4.0.2_7,1
	dovecot: 2.3.3 -> 2.3.3_2
	ca_root_nss: 3.39 -> 3.40
	boost-libs: 1.68.0_1 -> 1.68.0_2
	bind911: 9.11.4P2 -> 9.11.5
	apr: 1.6.3.1.6.1_1 -> 1.6.5.1.6.1
	apache24: 2.4.35 -> 2.4.37

Installed packages to be REINSTALLED:
	nut-2.7.4_8 (options changed)
	linux-c6-qt47-webkit-4.7.2_4 (direct dependency changed: linux-c6-qt47-x11)
	gimp-gutenprint-5.2.14 (needed shared library changed)

Number of packages to be removed: 5
Number of packages to be upgraded: 39
Number of packages to be reinstalled: 3

The operation will free 121 MiB.

Proceed with this action? [y/N]: y
...
[16/47] Deleting files for gvfs-1.30.4: 100%
[17/47] Upgrading gimp-app from 2.8.22_1,1 to 2.10.6_1,1...
[17/47] Extracting gimp-app-2.10.6_1,1:   0%
[17/47] Extracting gimp-app-2.10.6_1,1:   0%
[17/47] Extracting gimp-app-2.10.6_1,1:   1%
[17/47] Extracting gimp-app-2.10.6_1,1:   2%
[17/47] Extracting gimp-app-2.10.6_1,1:   3%
[17/47] Extracting gimp-app-2.10.6_1,1:   4%
[17/47] Extracting gimp-app-2.10.6_1,1:   5%
[17/47] Extracting gimp-app-2.10.6_1,1:   6%
pkg: Fail to create temporary file: /usr/local/libexec/gimp/2.2/plug-ins/align-layers/.align-layers.pD2NdeK0jYaA:Not a directory

[17/47] Extracting gimp-app-2.10.6_1,1: 100%

Command exit status: 0
Script done on Sun Oct 28 05:34:25 2018

The rest of the typescript from the above documents my (eventually successful) attempts to circumvent the problem.

This was on a system running:
FreeBSD albert.catwhisker.org 11.2-STABLE FreeBSD 11.2-STABLE #797  r339829M/339839: Sun Oct 28 03:39:42 PDT 2018     root@freebeast.catwhisker.org:/common/S1/obj/usr/src/sys/ALBERT  amd64


I note that this is the first time (of which I am aware) that I have encountered this issue since starting to use a weekly 'pkg upgrade' on this system since July, 2015.