Bug 232996 - graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault
Summary: graphics/gimp-app build broken: "../../tools/invert-svg" Segmentation fault
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-05 16:53 UTC by Michael Danilov
Modified: 2019-07-19 01:16 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
1. poudriere testport (262.27 KB, text/plain)
2018-11-05 16:53 UTC, Michael Danilov
no flags Details
2. disable Symbolic-Inverted in graphics/gimp-app (40.96 KB, patch)
2018-11-05 16:59 UTC, Michael Danilov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Danilov 2018-11-05 16:53:03 UTC
Created attachment 198982 [details]
1. poudriere testport

The "invert-svg" tool run during creation of Symbolic-Inverted theme segfaults.

As far as I get, this tool is using gegl, and so this crash could be related to graphics/gegl and openmp: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232990

Happens for both gegl 0.4.8_1 and 0.4.12.

I made a patch to fix the build by removing that theme.
Comment 1 Michael Danilov 2018-11-05 16:59:31 UTC
Created attachment 198984 [details]
2. disable Symbolic-Inverted in graphics/gimp-app
Comment 2 Michael Danilov 2018-12-31 10:47:14 UTC
Hey is anyone alive on this bug tracker anymore?
Comment 3 kunda 2019-07-19 01:16:12 UTC
Please test with latest gimp port 2.10.12