Bug 233012 - multimedia/qt5-multimedia fails to compile with pulseaudio
Summary: multimedia/qt5-multimedia fails to compile with pulseaudio
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-06 02:49 UTC by Brian Cully
Modified: 2018-11-24 10:18 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments
patch to pkg-plist that conditionalizes ALSA and PULSEAUDIO options. (1.58 KB, patch)
2018-11-06 02:49 UTC, Brian Cully
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Cully 2018-11-06 02:49:34 UTC
Created attachment 198997 [details]
patch to pkg-plist that conditionalizes ALSA and PULSEAUDIO options.

My options:

# This file is auto-generated by 'make config'.
# Options for qt5-multimedia-5.12.0.b3_1
_OPTIONS_READ=qt5-multimedia-5.12.0.b3_1
_FILE_COMPLETE_OPTIONS_LIST=GSTREAMER OPENAL ALSA PULSEAUDIO
OPTIONS_FILE_SET+=GSTREAMER
OPTIONS_FILE_UNSET+=OPENAL
OPTIONS_FILE_UNSET+=ALSA
OPTIONS_FILE_SET+=PULSEAUDIO

Attached patch allows me to compile with PULSEAUDIO by adjusting pkg-plist to only search for ALSA and PULSEAUDIO files if their respective options are selected during configuration.
Comment 1 Tobias C. Berner freebsd_committer 2018-11-24 09:03:12 UTC
Ahhhh, you are using one of the branches on github, that explains why I could not reproduce it in ports :D

Let me quickly fix it at the right place.


mfg Tobias
Comment 2 Tobias C. Berner freebsd_committer 2018-11-24 10:18:17 UTC
Moin moin

It is fixed now in branches/qt5-5.12 and branches/plasma5-5.13 


mfg Tobias