Bug 233087 - Should we remove hald from documentation and REQUIRE blocks in service files?
Summary: Should we remove hald from documentation and REQUIRE blocks in service files?
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-09 13:32 UTC by Mateusz Piotrowski
Modified: 2019-08-23 02:01 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Piotrowski freebsd_committer 2018-11-09 13:32:03 UTC
AFAIK, hald is not required anymore as its functionality has been replaced by devd (at least on FreeBSD).

If this is true, then we should probably do not mention hald in our documentation and remove it from various service files we've got in the ports tree.
Comment 1 Tilman Keskinoz freebsd_committer 2018-11-13 21:40:29 UTC
Maybe a bug isn't really the best place to discuss this? freebsd-ports@ or freebsd-gnome@ seem like a better audience.
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-08-08 09:09:20 UTC
There is a better place, to discuss this:

https://lists.freebsd.org/pipermail/freebsd-ports/

I close here, "not a bug".
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-23 02:01:28 UTC
^Triage: A closed issue  (this one) can't logically depend on an Open issue (bug 209532). Move it to See Also instead.