Bug 233118 - x11/gnome-session: build fails: does not validate _build/doc/dbus/*.dtd
Summary: x11/gnome-session: build fails: does not validate _build/doc/dbus/*.dtd
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-10 22:05 UTC by w.schwarzenfeld
Modified: 2018-11-17 13:02 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
svn-diff-gnome-session (2.24 KB, patch)
2018-11-11 01:20 UTC, w.schwarzenfeld
no flags Details | Diff
svn-diff-gnome-session_v2 (2.24 KB, patch)
2018-11-11 04:16 UTC, w.schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description w.schwarzenfeld freebsd_triage 2018-11-10 22:05:50 UTC
gnome-session 3.28.1 fails to build on 11.2-amd64-RELEASE with:

65/72] /usr/local/bin/xsltproc --output doc/dbus/org.gnome.SessionManager.ref.xml ../doc/dbus/spec-to-docbook.xsl /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.xml
error : Unknown IO error
/ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.xml:2: warning: failed to load external entity "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
spection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
                                                                               ^
[66/72] /usr/local/bin/meson --internal msgfmthelper data/gnome-dummy.session.desktop.in data/gnome-dummy.session desktop /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/po
[67/72] /usr/local/bin/xsltproc --output doc/dbus/org.gnome.SessionManager.Client.ref.xml ../doc/dbus/spec-to-docbook.xsl /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.Client.xml
error : Unknown IO error
/ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.Client.xml:2: warning: failed to load external entity "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
spection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
                                                                               ^
[68/72] /usr/local/bin/xsltproc --output doc/dbus/org.gnome.SessionManager.ClientPrivate.ref.xml ../doc/dbus/spec-to-docbook.xsl /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.ClientPrivate.xml
error : Unknown IO error
/ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.ClientPrivate.xml:2: warning: failed to load external entity "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
spection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
                                                                               ^
[69/72] /usr/local/bin/xsltproc --output doc/dbus/org.gnome.SessionManager.Inhibitor.ref.xml ../doc/dbus/spec-to-docbook.xsl /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.Inhibitor.xml
error : Unknown IO error
/ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.Inhibitor.xml:2: warning: failed to load external entity "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
spection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
                                                                               ^
[70/72] /usr/local/bin/xsltproc --output doc/dbus/org.gnome.SessionManager.Presence.ref.xml ../doc/dbus/spec-to-docbook.xsl /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.Presence.xml
error : Unknown IO error
/ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/gnome-session/org.gnome.SessionManager.Presence.xml:2: warning: failed to load external entity "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
spection 1.0//EN" "http://www.freedesktop.org/standards/dbus/1.0/introspect.dtd"
                                                                               ^
[71/72] /usr/local/bin/xmlto xhtml-nochunks -o /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/_build/doc/dbus -m ../doc/dbus/config.xsl doc/dbus/gnome-session.xml
FAILED: doc/dbus/gnome-session.html 
/usr/local/bin/xmlto xhtml-nochunks -o /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/_build/doc/dbus -m ../doc/dbus/config.xsl doc/dbus/gnome-session.xml
xmlto: /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/_build/doc/dbus/gnome-session.xml does not validate (status 3)
xmlto: Fix document syntax or use --skip-validation option
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
/ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/_build/doc/dbus/gnome-session.xml:8: warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
]>
  ^
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
validity error : Could not load the external subset "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
Document /ram/home/ngorx/temp/gnome-session/work/gnome-session-3.28.1/_build/doc/dbus/gnome-session.xml does not validate
[72/72] /usr/local/bin/xsltproc --output doc/man/gnome-session-inhibit.1 --nonet --stringparam man.output.quietly 1 --stringparam funcsynopsis.style ansi --stringparam man.th.extra1.suppress 1 --stringparam man.authors.section.enabled 0 --stringparam man.copyright.section.enabled 0 http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl ../doc/man/gnome-session-inhibit.xml
Warn: meta author : no refentry/info/author                        gnome-session-inhibit
Note: meta author : see http://docbook.sf.net/el/author            gnome-session-inhibit
Warn: meta author : no author data, so inserted a fixme            gnome-session-inhibit
ninja: build stopped: subcommand failed.
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1
Comment 1 w.schwarzenfeld freebsd_triage 2018-11-10 23:02:38 UTC
Found it, this was the cause
-<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
+<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN" "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
Comment 2 w.schwarzenfeld freebsd_triage 2018-11-10 23:39:00 UTC
Same error with gnome-session 3.30.1.
Comment 3 w.schwarzenfeld freebsd_triage 2018-11-11 01:20:08 UTC
Created attachment 199116 [details]
svn-diff-gnome-session
Comment 4 w.schwarzenfeld freebsd_triage 2018-11-11 04:16:22 UTC
Created attachment 199119 [details]
svn-diff-gnome-session_v2

Overlooked to change the version in the link.
Comment 5 Ting-Wei Lan 2018-11-17 12:03:34 UTC
As I said in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=233210#c8, is your docbook-xml installation broken? I cannot reproduce your problem and it seems to be specific to your machine.