Bug 233164 - dns/knot2: [patch] preparing for -utils and -lib ports.
Summary: dns/knot2: [patch] preparing for -utils and -lib ports.
Status: Closed DUPLICATE of bug 233199
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL: http://knot-dns.cz/
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-12 15:24 UTC by Leo Vandewoestijne
Modified: 2018-11-13 14:18 UTC (History)
0 users

See Also:
freebsd: maintainer-feedback-


Attachments
knot2 - metaports prepare (3.63 KB, patch)
2018-11-12 15:24 UTC, Leo Vandewoestijne
freebsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Vandewoestijne 2018-11-12 15:24:07 UTC
Created attachment 199168 [details]
knot2 - metaports prepare

Some users wish to have tools like kdig but do not wish to have the entire knot2 port.
Also there are users who only wish to have knot-resolver and do not wish to have knot2 - which brings libknot.
Therefor I made a patch which prepares dns/knot2 for two new metaports, dns/knot2-lib and dns/knot2-utils

This patch should be applied after commiting PR232947
Comment 1 Leo Vandewoestijne 2018-11-12 15:34:13 UTC
Comment on attachment 199168 [details]
knot2 - metaports prepare

Patch was tested both manual as in poudriedre.
Comment 2 Leo Vandewoestijne 2018-11-13 14:18:23 UTC
PR 233199 now includes all of this (PR 232947) and of PR 233199

*** This bug has been marked as a duplicate of bug 233199 ***