Bug 233199 - dns/knot2: [patch] upgrade to 2.7.4 and several fixes
Summary: dns/knot2: [patch] upgrade to 2.7.4 and several fixes
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL: https://www.knot-dns.cz/2018-11-13-ve...
Keywords:
: 232947 233164 (view as bug list)
Depends on:
Blocks: 233165 233167
  Show dependency treegraph
 
Reported: 2018-11-13 14:02 UTC by Leo Vandewoestijne
Modified: 2019-04-18 23:03 UTC (History)
1 user (show)

See Also:


Attachments
knot 2.7.4 (3.92 KB, patch)
2018-11-13 14:02 UTC, Leo Vandewoestijne
freebsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Vandewoestijne 2018-11-13 14:02:33 UTC
Created attachment 199204 [details]
knot 2.7.4

This patch:
 - upgrades from 2.7.3 to 2.7.4
And:
 - modifies to -when selected- use libidn2 in stead of libidn (as in PR 233164)
 - adds support for the MaxMind modules (as in PR 233164)
 - prepares for a new metaport dns/knot2-lib  (PR 233165)
 - prepares for a new metaport dns/knot2-utils (PR 233166)
 - fixes wrong ownership on directories (obsoletes PR 232947)
So:
 - obsoletes PR 232947
 - obsoletes PR 233164

Tested both manual as with Poudriere.
Comment 1 Leo Vandewoestijne 2018-11-13 14:18:23 UTC
*** Bug 233164 has been marked as a duplicate of this bug. ***
Comment 2 Leo Vandewoestijne 2018-11-13 14:31:50 UTC
To ease the committers life; the easiest order of committing will likely be:

1: PR233199
2: PR233165
3: PR233166
4: PR233167
Comment 3 commit-hook freebsd_committer 2018-11-23 15:35:25 UTC
A commit references this bug:

Author: swills
Date: Fri Nov 23 15:35:07 UTC 2018
New revision: 485677
URL: https://svnweb.freebsd.org/changeset/ports/485677

Log:
  dns/knot2: Upgrade to 2.7.4

  While here, improve options deps

  PR:		233199
  Submitted by:	Leo Vandewoestijne <freebsd@dns.company> (maintainer)

Changes:
  head/dns/knot2/Makefile
  head/dns/knot2/distinfo
  head/dns/knot2/pkg-plist
Comment 4 Steve Wills freebsd_committer 2018-11-23 15:36:17 UTC
Committed, thanks!
Comment 5 Kurt Jaeger freebsd_committer 2019-01-25 20:20:59 UTC
*** Bug 232947 has been marked as a duplicate of this bug. ***