Bug 233210 - devel/glib20: fails to configure: "XML DTD V4.1.2 in XML catalog... not found"
Summary: devel/glib20: fails to configure: "XML DTD V4.1.2 in XML catalog... not found"
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-13 22:01 UTC by Walter Schwarzenfeld
Modified: 2018-11-18 05:15 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
svn-diff-glib20 (1.70 KB, patch)
2018-11-14 12:21 UTC, Walter Schwarzenfeld
no flags Details | Diff
svn-diff-rm_patch_configure (921 bytes, patch)
2018-11-17 13:12 UTC, Walter Schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld freebsd_triage 2018-11-13 22:01:02 UTC
glib20 (2.56.1_3,1) fails to configure:

checking for DocBook XML DTD V4.1.2 in XML catalog... not found
===>  Script "configure" failed unexpectedly.
Please report the problem to gnome@FreeBSD.org [maintainer] and attach the
"/ram/usr/ports/devel/glib20/work/glib-2.56.3/config.log" including the output
of the failure of your make command. Also, it might be a good idea to provide
an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-11-13 22:05:58 UTC
change 4.1.2 to 4.2. After this: 

make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd glib/libcharset       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd glib/gnulib       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd glib/pcre       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd glib/tests       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd gmodule       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd gobject       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd gobject/tests       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd gthread       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd gio       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
config.status:2205: $? = 1
config.status:2198: cd gio/xdgmime       && sed -e '/# am--include-marker/d' Makefile         | make -f - am--depfiles
make[3]: illegal argument to -j -- must be positive integer!
........
onfig.status:2209: error: in `/ram/usr/ports/devel/glib20/work/glib-2.56.3':
config.status:2215: error: Something went wrong bootstrapping makefile fragments
    for automatic dependency tracking.  Try re-running configure with the
    '--disable-dependency-tracking' option to at least be able to build
    the package (albeit without support for automatic dependency tracking).
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-11-13 22:21:26 UTC
I could buld it with MAKE_JOBS_UNSAFE=yes
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-11-13 22:23:43 UTC
the XML error is also in bug #233118 (gnome-session).
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-11-13 23:05:08 UTC
The second error was caused by clang60, but it configures without the second problem with clang70 okay.
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-11-13 23:06:31 UTC
Sorry, was too fast. Does not configure with clang, but with GCC.
Comment 6 Walter Schwarzenfeld freebsd_triage 2018-11-14 12:21:42 UTC
Created attachment 199234 [details]
svn-diff-glib20

The patch-configure caused the error. Remove it solved the problem.
Comment 7 Walter Schwarzenfeld freebsd_triage 2018-11-14 18:35:01 UTC
This line in patch-configure cause the errors:

--  *-*-freebsd*|*-*-linux*)
-+  *-*-linux*)
-     G_THREAD_LIBS_FOR_GTHREAD="`echo $G_THREAD_LIBS | sed s/-pthread/-lpthread/`"
-     ;;

So I am not clear if we should remove the whole patch or only this change.
Comment 8 Ting-Wei Lan 2018-11-17 11:56:32 UTC
Is there any reason that docbook-xml doesn't install DTD files for version 4.1.2 on your machine? What 'pkg check -s docbook-xml' says and what is the content of your /usr/local/share/xml/catalog?

$ xmlcatalog --noout /usr/local/share/xml/catalog "-//OASIS//DTD DocBook XML V4.1.2//EN" 
/usr/local/share/xml/docbook/4.1.2/docbookx.dtd

$ pkg which /usr/local/share/xml/docbook/4.1.2/docbookx.dtd
/usr/local/share/xml/docbook/4.1.2/docbookx.dtd was installed by package docbook-xml-5.0_3
Comment 9 Walter Schwarzenfeld freebsd_triage 2018-11-17 12:03:30 UTC
Second command same output.
First:
xmlcatalog --noout /usr/local/share/xml/catalog "-//OASIS//DTD DocBook XML V4.1.2//EN"
No entry for PUBLIC -//OASIS//DTD DocBook XML V4.1.2//EN
Comment 10 Ting-Wei Lan 2018-11-17 12:08:31 UTC
What is the content of your /usr/local/share/xml/catalog? Does it points to a docbookx.dtd with version 4.1.2? You may have to follow the path specified with nextCatalog tag several times.

:: /usr/local/share/xml/catalog
<nextCatalog catalog="/usr/local/share/xml/catalog.ports" />

:: /usr/local/share/xml/catalog.ports
<nextCatalog catalog="/usr/local/share/xml/docbook/catalog.xml" />

:: /usr/local/share/xml/docbook/catalog.xml
<nextCatalog catalog="/usr/local/share/xml/docbook/4.1.2/catalog.xml" />

:: /usr/local/share/xml/docbook/4.1.2/catalog.xml
<public publicId="-//OASIS//DTD DocBook XML V4.1.2//EN" uri="docbookx.dtd"/>
Comment 11 Walter Schwarzenfeld freebsd_triage 2018-11-17 12:26:51 UTC
Reinstall of docbook-xml changed nothing.
Please, the exact syntax or can you paste the catalog file somewhere. I don't like xml and I have nearly never something to do with it.
Comment 12 Ting-Wei Lan 2018-11-17 12:42:40 UTC
These are files on one of my test machine:

$ cat /usr/local/share/xml/catalog
<?xml version="1.0"?>
<!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN"
    "http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd">

<!-- Created by XML Catalog Manager 2.2 -->
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
<nextCatalog catalog="/usr/local/share/xml/catalog.ports" />
</catalog>

$ cat /usr/local/share/xml/catalog.ports 
<?xml version="1.0"?>
<!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN" "http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd">

<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
<nextCatalog catalog="/usr/local/share/xml/xmlcharent/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xml/docbook/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xml/sdocbook/1.1/dtd/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xsl/docbook/catalog.xml" />
<system systemId="http://glade.gnome.org/glade-2.0.dtd" uri="/usr/local/share/xml/libglade/glade-2.0.dtd" />
<nextCatalog catalog="/usr/local/share/xsl/docbook-ns/catalog.xml" />
</catalog>

$ cat /usr/local/share/xml/docbook/catalog.xml
<?xml version="1.0"?>
<!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN"
    "http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd">

<!-- Created by XML Catalog Manager 2.2 -->
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
<nextCatalog catalog="/usr/local/share/xml/xmlcharent/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xml/docbook/4.1.2/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xml/docbook/4.2/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xml/docbook/4.3/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xml/docbook/4.4/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xml/docbook/4.5/catalog.xml" />
<nextCatalog catalog="/usr/local/share/xml/docbook/5.0/catalog.xml" />
</catalog>

$ head -n 30 /usr/local/share/xml/docbook/4.1.2/catalog.xml 
<?xml version='1.0'?>
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">

<!-- ...................................................................... -->
<!-- XML Catalog data for DocBook XML V4.1.2 .............................. -->
<!-- File catalog.xml ..................................................... -->

<!-- Please direct all questions, bug reports, or suggestions for
     changes to the docbook@lists.oasis-open.org mailing list. For more
     information, see http://www.oasis-open.org/.
  -->

<!-- This is the catalog data file for DocBook V4.1.2. It is provided as
     a convenience in building your own catalog files. You need not use
     the filenames listed here, and need not use the filename method of
     identifying storage objects at all.  See the documentation for
     detailed information on the files associated with the DocBook DTD.
     See XML Catalogs at http://www.oasis-open.org/committees/entity/ for
     detailed information on supplying and using catalog data.
  -->

<!-- ...................................................................... -->
<!-- DocBook driver file .................................................. -->

<public publicId="-//OASIS//DTD DocBook XML V4.1.2//EN"
        uri="docbookx.dtd"/>

<!-- ...................................................................... -->
<!-- DocBook modules ...................................................... -->
Comment 13 Walter Schwarzenfeld freebsd_triage 2018-11-17 13:01:53 UTC
I was a moment puzzled. This one is solved:

/usr/local/share/xml/docbook/4.1.2/catalog.xml
had V4.3 (why ever). Corrected it to 4.1.2 solved it.

Thanks for details.
Comment 14 Walter Schwarzenfeld freebsd_triage 2018-11-17 13:12:47 UTC
Created attachment 199291 [details]
svn-diff-rm_patch_configure
Comment 15 Walter Schwarzenfeld freebsd_triage 2018-11-17 13:18:38 UTC
Comment on attachment 199291 [details]
svn-diff-rm_patch_configure

No need to remove this patch. Also solved this problem. Close here with not a bug. Thank you, for your help.
Comment 16 Walter Schwarzenfeld freebsd_triage 2018-11-18 05:15:13 UTC
Found "why":
I had in the directory files a catalog412.xml with the V4.3 entries.
After I extracted the port new I had the right file.