Bug 233264 - www/serf: Add missing databases/gdbm dependency
Summary: www/serf: Add missing databases/gdbm dependency
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Lev A. Serebryakov
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2018-11-17 00:20 UTC by Patrick McMunn
Modified: 2019-11-03 22:10 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (lev)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick McMunn 2018-11-17 00:20:43 UTC
Please add

LIB_DEPENDS+=   libgdbm.so:databases/gdbm

to www/serf. Serf always gets broken and needs to be manually recompiled whenever gdbm is updated because portmaster doesn't handle it (I suppose because of the missing dependency).
Comment 1 Lev A. Serebryakov freebsd_committer 2018-11-19 11:56:49 UTC
It is wrong. serf doesn't depend on gdbm, it depends on devel/apr1, and devel/apr1 COULD depend on gdbm, but it is optional.

So, it should be solved by bumping PORTREVISION of serf (as it is done for devel/apr1) on each gdbm update.
Comment 2 Patrick McMunn 2018-11-21 01:24:27 UTC
Lev, your explanation makes sense. Serf does depend on apr which, in turn, depends on gdbm. It's just confusing because, for example, when I would try to run subversion (which depends on serf), the error message I received on the console said that serf depended on gdbm. The error output is somewhat misleading.
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-08-03 12:41:56 UTC
Is this problem still relevant?