Bug 233292 - x11-fm/doublecmd segementation fault freebsd 12.0-BETA4
Summary: x11-fm/doublecmd segementation fault freebsd 12.0-BETA4
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-18 13:24 UTC by SF
Modified: 2019-01-17 16:23 UTC (History)
1 user (show)

See Also:
linimon: maintainer-feedback? (bbtruk)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SF 2018-11-18 13:24:40 UTC
Since update to freebsd 12.0 beta iam getting "Segmentation fault (core dumped)" with doublecmd.
Comment 1 Beñat Gonzalez Etxepare 2018-11-20 20:18:08 UTC
(In reply to SF from comment #0)

I don't have access to a FreeBSD 12 machine right now, so I can't test it. Can you provide some debug info?

Are you using building the port yourself? or are you using packages built in another system? Also, have you tried with FreeBSD 12.0-RC1?
Comment 2 SF 2018-11-26 13:56:06 UTC
Pkg and port aren't working, trying upgrade to newest 12.0 is getting me stuck. I cannot do any upgrade anymore. It's stoping at pressing Enter at the end and doesn't succesfully complete with it, i cannot do the install command.
Comment 3 Beñat Gonzalez Etxepare 2018-11-30 12:20:58 UTC
(In reply to SF from comment #2)

Ok, with the lack of information I won't be able to help until I get hands on a FreeBSD 12 machine.

I will try to upgrade as soon as it is released around mid December and I will test it then.
Comment 4 Beñat Gonzalez Etxepare 2018-12-31 10:58:08 UTC
Hello,

I have been able to reproduce the error, but I am having some issues with FreeBSD 12 which do not let me debug the problem.

Meanwhile I have tested with a package of x11-fm/doublecmd built for FreeBSD 11 and it seems to work nicely under FreeBSD 12. So until it is resolved you can download the package for FreeBSD 11 and install it in your machine.
Comment 5 Beñat Gonzalez Etxepare 2019-01-10 06:34:40 UTC
(In reply to SF from comment #2)

A fix has been commited to x11-fm/doublecmd port (see bug #230806). Please test it and confirm it resolves the issue you are having. Thanks!
Comment 6 SF 2019-01-17 12:45:01 UTC
This still happens. I did completely reinstall FreeBSD 12.0 and doublecommand worked for an while, after pkg upgrade it's the same error again.
Comment 7 Beñat Gonzalez Etxepare 2019-01-17 16:23:52 UTC
(In reply to SF from comment #6)

Just to be sure: the version of x11-fm/doublecmd you have installed right now is the latest (0.8.4)?

Keep in mind the fix didn't make it in time for the quarterly branch, so you must use HEAD to get the latest version.