Bug 233293 - emulators/vice: new upstream version 3.2
Summary: emulators/vice: new upstream version 3.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-18 13:36 UTC by Felix Palmen
Modified: 2018-12-14 06:50 UTC (History)
2 users (show)

See Also:
dinoex: maintainer-feedback+


Attachments
upgrade vice to 3.2 (14.14 KB, patch)
2018-11-18 13:36 UTC, Felix Palmen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Palmen 2018-11-18 13:36:00 UTC
Created attachment 199315 [details]
upgrade vice to 3.2

Suggest upgrade to latest vice 3.2. Attached patch changes the following:

- Master site is sourceforge
- Added build dependency: devel/xa65
- Removed some unnecessary patches (did I overlook something here?)
- Removed GNOMEUI3 option, upstream doesn't support it -- revert default to GNOMEUI2. GTK3 UI is marked experimental, so didn't provide an option for it -- or should we?
- Replace GNU_CONFIGURE with HAS_CONFIGURE: upstream script doesn't support --disable-silent-rules
Comment 1 Nathan 2018-11-18 23:10:32 UTC
Comment on attachment 199315 [details]
upgrade vice to 3.2

SDL_CONFIGURE_ON=	--with-sdlsound
Can change to:
SDL_CONFIGURE_WITH= sdlsound

.if ${PORT_OPTIONS:MXAW}
USE_XORG+=	xaw
USES+=		readline
.endif
Can be replaced with:

XAW_USES= readline
XAW_USE= XORG=xaw
Comment 2 Dirk Meyer freebsd_committer 2018-11-19 17:18:16 UTC
1)
According to the webpage:
"...we will be switching to SDL1/2 and *nix/Windows/OSX native GTK3 ports for all future releases. "
I object axing out all GTK3 support.

2)
The PREFIX/LOCABASE patches are still needed.

3)
The INFO patches are still needed.

3)
share/info/vice.info should not be in plist,
this should be managed by INFO=

4)
path to manpages is broken.

5) re-enabling /dev/io needs testing.

Nathan)
SDL_CONFIGURE_WITH fails as there is no "without-sdlsound" option.


I will work on complete patch that addresses all the issues
and commit it after testing all UI versions.
Comment 3 commit-hook freebsd_committer 2018-12-13 20:49:15 UTC
A commit references this bug:

Author: dinoex
Date: Thu Dec 13 20:48:40 UTC 2018
New revision: 487383
URL: https://svnweb.freebsd.org/changeset/ports/487383

Log:
  - update to 3.2
  - option GNOMEUI2 default
  - new option GTK3
  PR:		233293
  Submitted by:	Felix Palmen

Changes:
  head/emulators/vice/Makefile
  head/emulators/vice/distinfo
  head/emulators/vice/files/patch-src_iodrv_io-unix-access.c
  head/emulators/vice/pkg-plist