Bug 233362 - Building riscv with BSD_CRTBEGIN fails
Summary: Building riscv with BSD_CRTBEGIN fails
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: riscv Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks: 228919
  Show dependency treegraph
 
Reported: 2018-11-20 22:06 UTC by Ed Maste
Modified: 2019-08-16 14:39 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2018-11-20 22:06:40 UTC
/usr/local/bin/riscv64-unknown-freebsd11.2-ld: /scratch/tmp/emaste/obj/scratch/tmp/emaste/freebsd/riscv.riscv64/tmp/usr/lib/crtbeginS.o: can't link hard-float modules with soft-float modules
/usr/local/bin/riscv64-unknown-freebsd11.2-ld: failed to merge target specific data of file /scratch/tmp/emaste/obj/scratch/tmp/emaste/freebsd/riscv.riscv64/tmp/usr/lib/crtbeginS.o
collect2: error: ld returned 1 exit status
Comment 1 Andrew Turner freebsd_committer 2018-11-21 18:29:43 UTC
How are you building this? I'm not able to reproduce.
Comment 2 Andrew Turner freebsd_committer 2019-08-14 14:45:03 UTC
Is this still an issue? BSD_CRTBEGIN should be enabled on riscv and I haven't heard any other complaints it fails to build.
Comment 3 Ed Maste freebsd_committer 2019-08-14 15:07:45 UTC
This was probably a temporary local problem, checking what config I had...
Comment 4 Ed Maste freebsd_committer 2019-08-16 14:39:51 UTC
I cannot reproduce this now.