Bug 233363 - Update devel/protobuf to 3.6.1
Summary: Update devel/protobuf to 3.6.1
Status: Closed DUPLICATE of bug 231008
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-21 00:29 UTC by Brad Davis
Modified: 2018-12-01 19:39 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
update to 3.6.1 (4.32 KB, patch)
2018-11-21 00:29 UTC, Brad Davis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Davis freebsd_committer 2018-11-21 00:29:28 UTC
Created attachment 199393 [details]
update to 3.6.1

Also svn rm the following files:

patch-src-google-protobuf-stubs-atomicops.h
patch-src_Makefile.am
Comment 1 Kevin Bowling freebsd_committer 2018-11-22 12:03:42 UTC
https://reviews.freebsd.org/D18296
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-11-29 19:47:48 UTC
Hi,

There are dependent ports need patches and PORTREVISION bump due to shlib change.
And protobuf itself need a patch for src/google/protobuf/stubs/common.h.
Please take a look at bug #231008.
Thanks!
Comment 3 Brad Davis freebsd_committer 2018-12-01 19:39:20 UTC

*** This bug has been marked as a duplicate of bug 231008 ***