Bug 233410 - mail/claws-mail: install: ./claws-mail-manual.pdf: No such file or directory
Summary: mail/claws-mail: install: ./claws-mail-manual.pdf: No such file or directory
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jochen Neumeister
URL:
Keywords:
: 233659 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-22 19:07 UTC by O. Hartmann
Modified: 2018-11-30 10:14 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (joneum)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-11-22 19:07:17 UTC
Trying to update my claws-mail-3.16.0_1 to laws-mail-3.17.1 fails with the error shown below.

I have already tried to update jade, docbook and related ports. Without success. The problem occurs on ALL(!) boxes I have installed claws-mail via /usr/ports and make.

[... lots of ...]

Working on: /usr/ports/mail/claws-mail/work/claws-mail-3.17.1/manual/dist/pdf/../../claws-mail-manual.xml
jade:E: cannot open "/usr/local/share/sgml/xml.dcl" (No such file or directory)
jade:/usr/ports/mail/claws-mail/work/claws-mail-3.17.1/manual/dist/pdf/../../claws-mail-manual.xml:3:13:E: character "_" invalid: only parameter literal, "CDATA", "ENDTAG", "MD", "MS", "PI", "PUBLIC", "SDATA", "STARTTAG", "SYSTEM" and parameter separators allowed

[...]
jade:/usr/local/share/sgml/docbook/dsssl/modular/print/../common/../common/dbl1mn.dsl:440:28:E: general entity "nav-home" not defined and no default entity
gmake[6]: [Makefile:650: claws-mail-manual.pdf] Error 8 (ignored)
 /bin/mkdir -p '/usr/ports/mail/claws-mail/work/stage/usr/local/share/doc/claws-mail/manual/en'
 install  -m 0644 ./claws-mail-manual.pdf '/usr/ports/mail/claws-mail/work/stage/usr/local/share/doc/claws-mail/manual/en'
install: ./claws-mail-manual.pdf: No such file or directory
gmake[6]: *** [Makefile:460: install-manualdeDATA] Error 71
gmake[6]: Leaving directory '/usr/ports/mail/claws-mail/work/claws-mail-3.17.1/manual/dist/pdf'
gmake[5]: *** [Makefile:529: install-am] Error 2
gmake[5]: Leaving directory '/usr/ports/mail/claws-mail/work/claws-mail-3.17.1/manual/dist/pdf'
gmake[4]: *** [Makefile:494: install-recursive] Error 1
gmake[4]: Leaving directory '/usr/ports/mail/claws-mail/work/claws-mail-3.17.1/manual/dist'
gmake[3]: *** [Makefile:509: install-recursive] Error 1
gmake[3]: Leaving directory '/usr/ports/mail/claws-mail/work/claws-mail-3.17.1/manual'
gmake[2]: *** [Makefile:778: install-recursive] Error 1
gmake[2]: Leaving directory '/usr/ports/mail/claws-mail/work/claws-mail-3.17.1'
*** Error code 2

Stop.
make[1]: stopped in /usr/ports/mail/claws-mail
*** Error code 1

Stop.
make: stopped in /usr/ports/mail/claws-mail
Comment 1 Jochen Neumeister freebsd_committer 2018-11-22 19:10:23 UTC
The problem is docbook-utils. Pls remove it and use textproc/docbook2X
Comment 2 Jochen Neumeister freebsd_committer 2018-11-30 10:14:14 UTC
*** Bug 233659 has been marked as a duplicate of this bug. ***