Bug 233421 - databases/xapian-core: Switch to gsed for configure
Summary: databases/xapian-core: Switch to gsed for configure
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks: 229925
  Show dependency treegraph
 
Reported: 2018-11-23 03:03 UTC by Kyle Evans
Modified: 2019-01-13 20:19 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
svn(1) diff against the ports tree (1.81 KB, patch)
2018-11-23 03:03 UTC, Kyle Evans
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle Evans freebsd_committer 2018-11-23 03:03:08 UTC
Created attachment 199465 [details]
svn(1) diff against the ports tree

Hi,

xapian-core's configure script tries to use \r as-in 'hard return', which isn't supported by our sed at this time -- this causes it to get passed through to regex(3) as an escape of an ordinary character, 'r'. Escaping of ordinary characters will not be allowed in future versions of regex(3), so switch to gsed for now until our sed supports some of the more common escape sequences; \r, \n, \t.

I'm including a diff that covers databases/xapian-core10 and databases/xapian-core12 as well; I understand you only maintain two of these, but I'd appreciate it if you could help shuffle the third one is as well given that it's the same patch.

Thanks!

Kyle Evans
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-11-25 15:21:25 UTC
I did a simple test on these ports with the following configuration:
- sed with original configure
- sed with modified configure (remove s/ *,\r$//)
- gsed with original configure
- gsed with modified configure (remove s/ *,\r$//)
The resulting include/xapian/version.h are identical.
Thus, I think a patch for configure is enough.
Comment 2 Kyle Evans freebsd_committer 2018-11-25 15:31:14 UTC
(In reply to Sunpoet Po-Chuan Hsieh from comment #1)

This is fine- given that it hasn't functioned as intended up to this point, I see no harm in just patching them out. Given that I have a lot of these to do and I'm the maintainer of none, I've tried to take the safe route and not give maintainers files/ patches to carry through until I get my sed/regex(3) work complete.

If you could test with the patch from issue 229925 applied to your libc, too, I'd appreciate it, or upload your patch so I can give it a test-through prior to commit to make sure all of the instances of extra escapes that will soon be forbidden are caught.
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-11-25 15:45:48 UTC
(In reply to Kyle Evans from comment #2)

I've submitted a review at https://reviews.freebsd.org/D18332. Thanks!
Comment 4 commit-hook freebsd_committer 2019-01-13 20:08:05 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Jan 13 20:07:45 UTC 2019
New revision: 490176
URL: https://svnweb.freebsd.org/changeset/ports/490176

Log:
  Remove unsupported regular expression

  Differential Revision:	https://reviews.freebsd.org/D18332
  PR:		233421
  Reported by:	kevans

Changes:
  head/databases/xapian-core/files/
  head/databases/xapian-core/files/patch-configure
Comment 5 commit-hook freebsd_committer 2019-01-13 20:09:08 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Jan 13 20:07:50 UTC 2019
New revision: 490177
URL: https://svnweb.freebsd.org/changeset/ports/490177

Log:
  Remove unsupported regular expression

  Differential Revision:	https://reviews.freebsd.org/D18332
  PR:		233421
  Reported by:	kevans

Changes:
  head/databases/xapian-core10/files/patch-configure
Comment 6 commit-hook freebsd_committer 2019-01-13 20:09:10 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Jan 13 20:07:55 UTC 2019
New revision: 490178
URL: https://svnweb.freebsd.org/changeset/ports/490178

Log:
  Remove unsupported regular expression

  Differential Revision:	https://reviews.freebsd.org/D18332
  PR:		233421
  Reported by:	kevans

Changes:
  head/databases/xapian-core12/files/patch-configure
Comment 7 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-01-13 20:19:17 UTC
Committed. Thanks!