Bug 233430 - OpenSSL 1.1.1a SIGSEGV
Summary: OpenSSL 1.1.1a SIGSEGV
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 12.0-STABLE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks: 231931
  Show dependency treegraph
 
Reported: 2018-11-23 08:03 UTC by Loïc Bartoletti
Modified: 2019-01-10 14:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Loïc Bartoletti 2018-11-23 08:03:58 UTC
Hi,

I have a problem since upgrading from openssl to version 1.1.1a.

I'm working on graphics/QGIS 3 and at startup I have a crash with this error.

Thread 1 received signal SIGSEGV. Segmentation fault.
ssl3_release_write_buffer (s=0x0)
    at /usr/src/crypto/openssl/ssl/record/ssl3_buffer.c:159


I suspect that the module calling openssl is qca-qt5 with the openssl plugins.

This works very well with version 1.1.1.1 (svn rev 340700 for example)
Comment 1 Loïc Bartoletti 2019-01-10 14:24:47 UTC
I tried again on other machines without reproducing the problem. I think there was an error in the update on my test machine.