Bug 233501 - multimedia/gstreamer-plugins-buzztard: fails to build with fluidsynth 2.x
Summary: multimedia/gstreamer-plugins-buzztard: fails to build with fluidsynth 2.x
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords: needs-patch
Depends on:
Blocks: 233448
  Show dependency treegraph
 
Reported: 2018-11-25 11:57 UTC by Jan Beich
Modified: 2018-12-22 17:56 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (multimedia)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-11-25 11:57:36 UTC
src/fluidsynth/gstfluidsynth.c:258:64: error: too few arguments to function call, expected 3, have 2
      ddef = fluid_settings_getnum_default (bag->settings, name);
             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                     ^
/usr/local/include/fluidsynth/settings.h:134:1: note: 'fluid_settings_getnum_default' declared here
FLUIDSYNTH_API
^
/usr/local/include/fluidsynth.h:47:24: note: expanded from macro 'FLUIDSYNTH_API'
#define FLUIDSYNTH_API __attribute__ ((visibility ("default")))
                       ^
src/fluidsynth/gstfluidsynth.c:264:64: error: too few arguments to function call, expected 3, have 2
      idef = fluid_settings_getint_default (bag->settings, name);
             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                     ^
/usr/local/include/fluidsynth/settings.h:147:1: note: 'fluid_settings_getint_default' declared here
FLUIDSYNTH_API
^
/usr/local/include/fluidsynth.h:47:24: note: expanded from macro 'FLUIDSYNTH_API'
#define FLUIDSYNTH_API __attribute__ ((visibility ("default")))
                       ^
src/fluidsynth/gstfluidsynth.c:269:66: error: too few arguments to function call, expected 3, have 2
      defstr = fluid_settings_getstr_default (bag->settings, name);
               ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~                     ^
/usr/local/include/fluidsynth/settings.h:122:1: note: 'fluid_settings_getstr_default' declared here
FLUIDSYNTH_API
^
/usr/local/include/fluidsynth.h:47:24: note: expanded from macro 'FLUIDSYNTH_API'
#define FLUIDSYNTH_API __attribute__ ((visibility ("default")))
                       ^
src/fluidsynth/gstfluidsynth.c:413:11: error: use of undeclared identifier 'FLUID_CHORUS_DEFAULT_TYPE'
          FLUID_CHORUS_DEFAULT_TYPE,
          ^

build log: https://ptpb.pw/zwBz
Comment 1 Tobias Kortkamp freebsd_committer 2018-11-25 14:08:46 UTC
The module is unused in the ports tree, has been renamed to
gst-buzztrax [0], which has been discontinued [1] upstream in
2015.  We probably should just deprecate and remove it.

New WWW is https://news.buzztrax.org/

[0] https://github.com/Buzztrax/gst-buzztrax/commit/10e18f63b513060b3ef657e493d75ac035bb2ded
[1] https://github.com/Buzztrax/gst-buzztrax/commit/3faf9eb12dd8cb7514650bd51f1f09fe590528d8
Comment 2 commit-hook freebsd_committer 2018-12-08 10:20:21 UTC
A commit references this bug:

Author: tobik
Date: Sat Dec  8 10:19:52 UTC 2018
New revision: 486936
URL: https://svnweb.freebsd.org/changeset/ports/486936

Log:
  Deprecate multimedia/gstreamer-plugins-buzztard

  The module does not build with FluidSynth 2.x, is unused in the
  ports tree, has been renamed to gst-buzztrax [0], which has been
  discontinued upstream [1] in 2015.

  While here update WWW.

  [0] https://github.com/Buzztrax/gst-buzztrax/commit/10e18f63b513060b3ef657e493d75ac035bb2ded
  [1] https://github.com/Buzztrax/gst-buzztrax/commit/3faf9eb12dd8cb7514650bd51f1f09fe590528d8

  PR:		233501

Changes:
  head/multimedia/gstreamer-plugins-buzztard/Makefile
  head/multimedia/gstreamer-plugins-buzztard/pkg-descr
Comment 3 Rene Ladan freebsd_committer 2018-12-22 17:56:26 UTC
Expired port removed.