Bug 233512 - devel/guile-lib: Fix missing dependency
Summary: devel/guile-lib: Fix missing dependency
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-25 18:45 UTC by Nathan
Modified: 2019-01-12 20:33 UTC (History)
0 users

See Also:


Attachments
Fix pkg-fallout (1.06 KB, text/plain)
2018-11-25 18:45 UTC, Nathan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan 2018-11-25 18:45:07 UTC
Created attachment 199551 [details]
Fix pkg-fallout

devel/guile-lib:                                                                               
                                                                                             
* Fix missing libiconv depend                                                                  
* Correct order of variables, per handbook                                                     
                                                                                         
Submitted by:   ndowens@yahoo.com                                                              
Approved by:    ndowens@yahoo.com(maintainer)

Tested on 12/13 amd64 poudriere

Used LIB_DEPENDS instead of USES=iconv did not work with configure script
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2018-11-26 16:51:21 UTC
antoine@ has added explicit USES=iconv to devel/guile2 in r485846. I've built devel/guile-lib successfully after that commit.
Comment 2 Nathan 2018-11-26 17:01:37 UTC
(In reply to Sunpoet Po-Chuan Hsieh from comment #1)
I tried it in poudriere and got the same error as the pkg-fallout msg. I tried adding USES=iconv but that didn’t solve it for me
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-01-06 10:35:09 UTC
Did you still get pkg-fallout notification? I cannot reproduce the failure on 11.2-RELEASE and 12.0-RELEASE after r485846.
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-01-12 20:33:21 UTC
I'm closing this PR. Please feel free to reopen it if necessary. Thanks!