Bug 233658 - security/clamav: Shared object "libclammspack.so.0" not found, required by "clamd"
Summary: security/clamav: Shared object "libclammspack.so.0" not found, required by "c...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Larry Rosenman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-30 09:55 UTC by O. Hartmann
Modified: 2018-11-30 10:54 UTC (History)
1 user (show)

See Also:
ohartmann: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-11-30 09:55:54 UTC
After an update of several ports on CURRENT (FreeBSD 13.0-CURRENT #869 r341328: Fri Nov 30 09:04:32 CET 2018 amd64), clamav-clamd service rejects starting with the error:

ld-elf.so.1: Shared object "libclammspack.so.0" not found, required by "clamd"

The library in question, libclammspack.so.0, is not installed at all. Port archivers/libmspack is installed and up to date (checked by reinstalling).

The problem couldn't be solved by deinstalling all clamav ports and checking for possible influencing remnants.

Looking for similar problems I found lots of issues regaridng the very same problem on Linux which seem to be solved. So I'm wondering why the issue pops up in FreeBSD now.
Comment 1 O. Hartmann 2018-11-30 09:58:25 UTC
The issue can be temporarily solved by disabling option "MSPACK" and using the bundled libmspack.
Comment 2 Larry Rosenman freebsd_committer 2018-11-30 10:01:17 UTC
This is related to the update I pushed yesterday.  Let me investigate some more.
Comment 3 Larry Rosenman freebsd_committer 2018-11-30 10:13:13 UTC
I've committed a fix, please let me know of more issues.
Comment 4 commit-hook freebsd_committer 2018-11-30 10:13:37 UTC
A commit references this bug:

Author: ler
Date: Fri Nov 30 10:12:45 UTC 2018
New revision: 486243
URL: https://svnweb.freebsd.org/changeset/ports/486243

Log:
  security/clamav: install libclammspack regardless of the MSPACK option.

  PR:		233658
  Reported by:	ohartmann@walstatt.org

Changes:
  head/security/clamav/Makefile
  head/security/clamav/pkg-plist
Comment 5 commit-hook freebsd_committer 2018-11-30 10:54:11 UTC
A commit references this bug:

Author: ler
Date: Fri Nov 30 10:53:40 UTC 2018
New revision: 486246
URL: https://svnweb.freebsd.org/changeset/ports/486246

Log:
  security/clamav: really do the right thing with the MSPACK option.

  previous patch added the configure argument to find archivers/libmspack
  installed, but neglected to set USES+= pkgconfig to actually have the binary
  use that version.  With it now properly finding libmspack.so, revert to
  not trying to install libclammspack* if the MSPACK option is set.

  PR:		233658

Changes:
  head/security/clamav/Makefile
  head/security/clamav/pkg-plist