Bug 233659 - mail/claws-mail: build failure: jade:E: cannot open "/usr/local/share/sgml/xml.dcl" (No such file or directory)
Summary: mail/claws-mail: build failure: jade:E: cannot open "/usr/local/share/sgml/xm...
Status: Closed DUPLICATE of bug 233410
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jochen Neumeister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-30 10:04 UTC by O. Hartmann
Modified: 2018-11-30 10:14 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (joneum)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-11-30 10:04:30 UTC
Builkding port mail/claws-mail after the update to 3.17.1 on recent CURRENT and 12-STABLE results in a failure as shown below. The error also occurs even when option for building DOCS is disabled!

[...]
docbook2pdf -o . ../../claws-mail-manual.xml                                                                                                                                                                                  
Using catalogs: /usr/local/share/sgml/catalog, /usr/local/share/sgml/docbook/dsssl/modular/catalog, /usr/local/share/sgml/docbook/dsssl/modular/common/catalog,                                                               /usr/local/share/sgml/docbook/dsssl/modular/dtds/html/catalog, /usr/local/share/sgml/docbook/dsssl/modular/html/catalog, /usr/local/share/sgml/docbook/dsssl/mod                                                              ular/print/catalog, /usr/local/share/sgml/docbook/catalog, /usr/local/share/sgml/iso8879/catalog, /usr/local/share/sgml/html/catalog, /usr/local/share/sgml/jade                                                              /catalog, /usr/local/share/sgml/openjade/OpenSP/catalog, /usr/local/share/sgml/openjade/catalog                                                                                                                               
Using stylesheet: /usr/local/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl#print   
                                                                                                                                       
Working on: /usr/ports/mail/claws-mail/work/claws-mail-3.17.1/manual/dist/pdf/../../claws-mail-manual.xml                                                                                                                     
jade:E: cannot open "/usr/local/share/sgml/xml.dcl" (No such file or directory)
[...]
gmake[6]: [Makefile:650: claws-mail-manual.pdf] Error 8 (ignored)
/bin/mkdir -p '/usr/ports/mail/claws-mail/work/stage/usr/local/share/doc/claws-mail/manual/en'
install  -m 0644 ./claws-mail-manual.pdf '/usr/ports/mail/claws-mail/work/stage/usr/local/share/doc/claws-mail/manual/en'
install: ./claws-mail-manual.pdf: No such file or directory
Comment 1 Jochen Neumeister freebsd_committer 2018-11-30 10:14:14 UTC

*** This bug has been marked as a duplicate of bug 233410 ***