Bug 233672 - [area51] Fix build failures caused by linux/input.h header file move.
Summary: [area51] Fix build failures caused by linux/input.h header file move.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-30 19:13 UTC by Brian Cully
Modified: 2018-12-17 14:41 UTC (History)
6 users (show)

See Also:


Attachments
Patch to various Makefiles BUILD_DEPENDS rules. (3.79 KB, patch)
2018-11-30 19:13 UTC, Brian Cully
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Cully 2018-11-30 19:13:04 UTC
Created attachment 199693 [details]
Patch to various Makefiles BUILD_DEPENDS rules.

When building with Wayland support, many ports fail to compile due to a recent move of the linux/input.h header file from the multimedia/v4l_compat port to devel/evdev-proto.

Attached is a patch that adjusts the BUILD_DEPENDS rules to point to the new location for the header file.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2018-11-30 22:47:07 UTC
Take a guess and assign to kde@ and Cc: all other maintainers.

audio/ardour                            danfe@FreeBSD.org
devel/sdl20                             amdmi3@FreeBSD.org
multimedia/gstreamer1-plugins           multimedia@FreeBSD.org
multimedia/kdenlive                     kde@FreeBSD.org
net/freerdp                             kevans@FreeBSD.org
x11-drivers/xf86-video-qxl              ports@FreeBSD.org
Comment 2 Tobias C. Berner freebsd_committer 2018-12-16 19:17:04 UTC
Thanks, committed to branches/plasma5-5.13.

mfg Tobias
Comment 3 Kyle Evans freebsd_committer 2018-12-16 20:57:02 UTC
Not that I have any concerns or anything with this, but is area51 purely a KDE thing or...?
Comment 4 Tobias C. Berner freebsd_committer 2018-12-16 21:20:55 UTC
(In reply to Kyle Evans from comment #3)
Yep, area51 was the name of kde@'s development repository before we moved it to github.
Comment 5 Adriaan de Groot freebsd_committer 2018-12-17 14:41:47 UTC
To elaborate: several FreeBSD (sub-)projects have their own fork of the FreeBSD ports tree on GitHub. KDE has one, and we call it Area51 for historical reasons. kde@ keeps a bunch of branches in-flight there, generally for upcoming releases of things: for instance, Plasma 5.13 (which has been blocked for a long time due to libinput).

tcberner@ has committed https://github.com/freebsd/freebsd-ports-kde/commit/3964d583f8b55f7f77b43dfe54d4f3a2017b791a which has no effect the official ports tree for now. Other ports (e.g. ardour) should consider whether to patch by themselves, or "just" wait for the merge of this branch.