Bug 233677 - sysutils/vagrant: update to 2.2.2
Summary: sysutils/vagrant: update to 2.2.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Christoph Moench-Tegeder
URL: https://github.com/hashicorp/vagrant/...
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2018-11-30 23:32 UTC by Christoph Moench-Tegeder
Modified: 2018-11-30 23:59 UTC (History)
1 user (show)

See Also:
joe: maintainer-feedback+


Attachments
update vagrant to 2.2.2 (1.73 KB, patch)
2018-11-30 23:32 UTC, Christoph Moench-Tegeder
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Moench-Tegeder freebsd_committer 2018-11-30 23:32:21 UTC
Created attachment 199699 [details]
update vagrant to 2.2.2

A new release, once again.
This release is said to fix an regression with the new default NIC type for virtualbox guests, see
 - https://github.com/hashicorp/vagrant/pull/10383
 - https://github.com/hashicorp/vagrant/issues/10448
 - https://github.com/hashicorp/vagrant/pull/10450

I can't reproduce the problem, and don't see regressions with the fix (but then, as far as this PR here is concerned, my host is running neither MacOS nor Ubuntu, for very obvious reasons).

Anyways, let's have the patch so we get rid of vagrant's upgrade notifier and stay close to upstream.
Comment 1 commit-hook freebsd_committer 2018-11-30 23:59:23 UTC
A commit references this bug:

Author: cmt
Date: Fri Nov 30 23:58:20 UTC 2018
New revision: 486306
URL: https://svnweb.freebsd.org/changeset/ports/486306

Log:
  sysutils/vagrant: update to 2.2.2

  https://github.com/hashicorp/vagrant/blob/v2.2.2/CHANGELOG.md
  Fixes regressins in the default NIC type handling. Watch for regressions
  in the regression fix.

  PR:		233677
  Approved by:	joe at thrallingpengion dot com (maintainer)

Changes:
  head/sysutils/vagrant/Makefile
  head/sysutils/vagrant/distinfo
  head/sysutils/vagrant/pkg-plist
Comment 2 Christoph Moench-Tegeder freebsd_committer 2018-11-30 23:59:57 UTC
committed ports r486306 , thanks.