Bug 233703 - audio/mumble: ld-elf.so.1: Shared object "libcrypto.so.8" not found, required by "mumble"
Summary: audio/mumble: ld-elf.so.1: Shared object "libcrypto.so.8" not found, required...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mark Felder
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-01 20:58 UTC by Alexander Sieg
Modified: 2019-03-21 14:08 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (feld)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Sieg 2018-12-01 20:58:56 UTC
ld-elf.so.1: Shared object "libcrypto.so.8" not found, required by "mumble"

Even after full rebuild, also the port is not available through pkg.
Comment 1 Mark Felder freebsd_committer 2019-03-21 14:08:44 UTC
This sounds to me like a broken OS install/upgrade. Were you moving from FreeBSD 11 to 12 by chance? libcrypto.so.8 is part of the base OS in FreeBSD 11. It seems to me like you were running FreeBSD 11 packages on a FreeBSD 12 install to get that error, or something similar to it.

If you were truly missing libcrypto.so.8 a lot of software would not work.