Bug 233732 - Possible race condition in build process: unexpected token in '.rept' directive (PTI_SIZE)
Summary: Possible race condition in build process: unexpected token in '.rept' directi...
Status: Closed DUPLICATE of bug 233339
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-02 20:44 UTC by Li-Wen Hsu
Modified: 2018-12-04 15:50 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Li-Wen Hsu freebsd_committer 2018-12-02 20:44:44 UTC
Failed runs:

https://ci.freebsd.org/job/FreeBSD-head-amd64-build/11094/console
https://ci.freebsd.org/job/FreeBSD-head-amd64-build/10937/console
https://ci.freebsd.org/job/FreeBSD-head-amd64-build/10034/console
https://ci.freebsd.org/job/FreeBSD-head-amd64-build/9858/console

Console output:

--- all_subdir_hyperv ---
<instantiation>:2:8: error: unexpected token in '.rept' directive
 .rept ((PTI_SIZE / 8) - 1 + 0)
       ^
<instantiation>:5:2: note: while in macro instantiation
 MOVE_STACKS ((PTI_SIZE / 8) - 1 + 0)
 ^
<instantiation>:6:2: note: while in macro instantiation
 PTI_UUENTRY 0
 ^
<instantiation>:7:2: note: while in macro instantiation
 PTI_UENTRY has_err=0
 ^
<instantiation>:2:2: note: while in macro instantiation
 PTI_INTRENTRY vmbus_isr
 ^
/usr/src/sys/dev/hyperv/vmbus/amd64/vmbus_vector.S:41:2: note: while in macro instantiation
 INTR_HANDLER vmbus_isr
 ^
Comment 3 Mark Johnston freebsd_committer 2018-12-04 15:46:10 UTC
This one appears to be a dup of 233339.  Looking through the logs, I see:

nm: 'genassym.o': No such file or directory
Comment 4 Mark Johnston freebsd_committer 2018-12-04 15:50:19 UTC

*** This bug has been marked as a duplicate of bug 233339 ***