Bug 233741 - devel/tex-kpathsea: Outputs indexinfo warnings
Summary: devel/tex-kpathsea: Outputs indexinfo warnings
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Hiroki Sato
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2018-12-03 05:21 UTC by jszhao
Modified: 2018-12-03 11:21 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (hrs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jszhao 2018-12-03 05:21:03 UTC
After installation or upgradation of tex-kpathsea using pkg, I got lots warning 
such as:

indexinfo: Skipping: asy-faq.info: Capabilities insufficient
...
indexinfo: Skipping: web2c.info: Capabilities insufficient
indexinfo: Impossible to write the index file: Capabilities insufficient

And those warnings repeated several times.

I don't install any component of TeX/LaTeX distribution except for 
tex-kpathsea package, which was required by maxima, octave, etc. I have updated to the latest version of FreeBSD and pkg.

What's the problem? and how to avoid those warnings.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-03 05:40:20 UTC
Assign to maintainer

CC bapt as this may be related to ports r484628 (See Also: bug 232907)
Comment 2 Baptiste Daroussin freebsd_committer 2018-12-03 07:25:58 UTC
This has nothing to do with the change listed here.

This only has to do with capsicum, is it possible to get the output of
pkg -vv
uname -UK

please
Comment 3 jszhao 2018-12-03 07:44:52 UTC
(In reply to Baptiste Daroussin from comment #2)

root@xw6600:/root # pkg -vv
Version                 : 1.10.5

REPO_AUTOUPDATE = true;
NAMESERVER = "";
HTTP_USER_AGENT = "pkg/1.10.5";
EVENT_PIPE = "";
FETCH_TIMEOUT = 300;
UNSET_TIMESTAMP = false;
SSH_RESTRICT_DIR = "";
PKG_ENV {
}
PKG_SSH_ARGS = "";
DEBUG_LEVEL = 0;
ALIAS {
    all-depends = "query %dn-%dv";
    annotations = "info -A";
    build-depends = "info -qd";
    cinfo = "info -Cx";
    comment = "query -i \"%c\"";
    csearch = "search -Cx";
    desc = "query -i \"%e\"";
    download = "fetch";
    iinfo = "info -ix";
    isearch = "search -ix";
    prime-list = "query -e '%a = 0' '%n'";
    leaf = "query -e '%#r == 0' '%n-%v'";
    list = "info -ql";
    noauto = "query -e '%a == 0' '%n-%v'";
    options = "query -i \"%n - %Ok: %Ov\"";
    origin = "info -qo";
    provided-depends = "info -qb";
    raw = "info -R";
    required-depends = "info -qr";
    roptions = "rquery -i \"%n - %Ok: %Ov\"";
    shared-depends = "info -qB";
    show = "info -f -k";
    size = "info -sq";
}
CUDF_SOLVER = "";
SAT_SOLVER = "";
RUN_SCRIPTS = true;
CASE_SENSITIVE_MATCH = false;
LOCK_WAIT = 1;
LOCK_RETRIES = 5;
SQLITE_PROFILE = false;
WORKERS_COUNT = 0;
READ_LOCK = false;
PLIST_ACCEPT_DIRECTORIES = false;
IP_VERSION = 0;
AUTOMERGE = true;
VERSION_SOURCE = "";
CONSERVATIVE_UPGRADE = true;
PKG_CREATE_VERBOSE = false;
AUTOCLEAN = false;
DOT_FILE = "";
REPOSITORIES {
}
VALID_URL_SCHEME [
    "pkg+http",
    "pkg+https",
    "https",
    "http",
    "file",
    "ssh",
    "ftp",
    "ftps",
    "pkg+ssh",
    "pkg+ftp",
    "pkg+ftps",
]
ALLOW_BASE_SHLIBS = false;
WARN_SIZE_LIMIT = 1048576;
METALOG = "";
OSVERSION = 1102000;
IGNORE_OSVERSION = false;


Repositories:
  FreeBSD: {
    url             : "pkg+http://pkgmir.geo.freebsd.org/FreeBSD:11:amd64/latest",
    enabled         : yes,
    priority        : 0,
    mirror_type     : "SRV",
    signature_type  : "FINGERPRINTS",
    fingerprints    : "/usr/share/keys/pkg"
  }

root@xw6600:/root # uname -UK
1102000 1102000
Comment 4 jszhao 2018-12-03 07:59:13 UTC
I list the directory of /usr/local/share/info/, and find that all the info files in the warning message are file links pointing to a non-exist destination. 

For example,

root@xw6600:/usr/local/share/info # ls -al web2c.info
lrwxr-xr-x  1 root  wheel  47 Apr  6  2016 web2c.info -> /usr/local/share/texmf-dist/doc/info/web2c.info

however, there are no ``doc'' directory in /usr/local/share/texmf-dist/.

Is it the root of these warnings?
Comment 5 Baptiste Daroussin freebsd_committer 2018-12-03 08:09:22 UTC
It seems you do need to reinstall tex-web2c and asymptote.

For some reasons you ended up with symlinks where the packages are not installing any symlinks (this is the reason why indexinfo is complaining about those files)
Comment 6 jszhao 2018-12-03 08:35:22 UTC
I don't install any components belonging to TeX distribution. The only related package, tex-kpathsea was installed by other package as dependency. Thus, I think it may be safe to delete all the links. And, after I delete all the broken links, the warning messages disappear.
Comment 7 Baptiste Daroussin freebsd_committer 2018-12-03 11:21:48 UTC
yes this is it :)