Bug 233798 - net/qt5-network: Fails to run: libqgenericbearer.so: Undefined symbol "ZN17QNetworkInterfaceC1ERKS@Qt_5"
Summary: net/qt5-network: Fails to run: libqgenericbearer.so: Undefined symbol "ZN17QN...
Status: Closed DUPLICATE of bug 231402
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: kde
URL: https://github.com/trueos/trueos-port...
Keywords:
Depends on:
Blocks: 232318
  Show dependency treegraph
 
Reported: 2018-12-05 11:58 UTC by Nils Beyer
Modified: 2018-12-31 02:56 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (kde)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nils Beyer 2018-12-05 11:58:17 UTC
Hi,

"kded5" fails to run, reporting:

    ld-elf.so.1: /usr/local/lib/qt5/plugins/bearer/libqgenericbearer.so: Undefined symbol "ZN17QNetworkInterfaceC1ERKS@Qt_5"

Issue is explained in detail here:

    https://github.com/project-trident/trident-core/issues/26

Workaround is here:

    https://github.com/trueos/trueos-ports/pull/65/commits/1b6853788364042f1e5bd4373efb5c84e60fe0c3#diff-8fa76113cb75f7770fc49902897f7cf9

I am using VLAN config lines in my "rc.conf"...



Thanks,
Nils
Comment 1 Adriaan de Groot freebsd_committer 2018-12-21 13:17:15 UTC
A **workaround** is to add QT_EXCLUDE_GENERIC_BEARER=1 to your environment.
Comment 2 Adriaan de Groot freebsd_committer 2018-12-21 16:13:16 UTC
The TrueOS commits -- which to me just randomly comment something out because that's triggering the symbol problem, which is something you can also do with the environment variable -- say this:

   This started to happen after upgrade to Qt5.11.2.

Could you confirm that this **did** work before Qt 5.11.2?
Comment 3 Nils Beyer 2018-12-21 18:15:27 UTC
(In reply to Adriaan de Groot from comment #2)

I'm neither the comitter at TrueOS nor one of the issue participants there; just a random guy that happens to also be affected by that...
Comment 4 Adriaan de Groot freebsd_committer 2018-12-21 22:05:53 UTC
Closing as duplicate: 231402 is still open, and contains a bunch of debugging effort to try to figure out what's going wrong internally.

*** This bug has been marked as a duplicate of bug 231402 ***
Comment 5 commit-hook freebsd_committer 2018-12-24 16:46:24 UTC
A commit references this bug:

Author: adridg
Date: Mon Dec 24 16:46:18 UTC 2018
New revision: 488276
URL: https://svnweb.freebsd.org/changeset/ports/488276

Log:
  Fix net/qt5-network in the face of VLANs.

  Adding a VLAN to a FreeBSD system caused memory corruption -- usually
  enough to make rtld fall over with symbol resolution errors, although
  in DEBUG builds it would just crash. Revamp network interface discovery
  to not be full of memory gotcha's.

  An explanation is included in the patches. While here, "make makesum"
  has moved some files around.

  PR:		231402, 233798, 232318
  Reported by:	Ting-Wei Lan, Nils Beyer, Marek Zarychta

Changes:
  head/net/qt5-network/Makefile
  head/net/qt5-network/files/patch-qsslcontext_openssl.cpp
  head/net/qt5-network/files/patch-src_network_kernel_qnetworkinterface__unix.cpp
  head/net/qt5-network/files/patch-src_network_socket_qnet__unix__p.h
  head/net/qt5-network/files/patch-src_network_socket_qnet_unix_p.h
  head/net/qt5-network/files/patch-src_network_ssl_qsslcontext__openssl.cpp
  head/net/qt5-network/files/patch-src_plugins_bearer_generic_qgenericengine.cpp
Comment 6 Max 2018-12-31 01:29:15 UTC
(In reply to Adriaan de Groot from comment #2)

Hello Adriaan,

Yes, the issue did not appear with the version 5.9.5 (prior version on older TrueOS)


I am going to check out the environment variable workaround as well. Thanks for reference.


Thanks,
Max
Comment 7 Max 2018-12-31 02:56:19 UTC
(In reply to commit-hook from comment #5)

I've just tested this merged commit and can confirm that the issue seems to be fixed now

Although I noticed that when QT_NO_NETWORK_INTERFACE option is used qt5-network does not compile so you might still like check out the following patch: https://github.com/trueos/trueos-ports/pull/65/files