Bug 233823 - [NEW PORT] security/py-python-axolotl: Python port of libaxolotl-android
Summary: [NEW PORT] security/py-python-axolotl: Python port of libaxolotl-android
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: feature, needs-patch, needs-qa
Depends on: 233822
Blocks:
  Show dependency treegraph
 
Reported: 2018-12-06 11:43 UTC by Goran Mekić
Modified: 2018-12-07 06:01 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (meka)


Attachments
py-axolotl.shar (1.53 KB, text/plain)
2018-12-06 11:43 UTC, Goran Mekić
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Mekić 2018-12-06 11:43:43 UTC
Created attachment 199887 [details]
py-axolotl.shar
Comment 1 Goran Mekić 2018-12-06 11:45:46 UTC
This library is used in net-im/gajim plugin for OMEMO
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-07 05:33:17 UTC
Thank you for submitting a new FreeBSD ports Goran. A couple of review items:

Upstream/canonical name is 'python-axolotl' [1], please rename.

There are missing *_DEPENDS. See setup.py:deps/install_requires

[1] https://pypi.org/project/python-axolotl/
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-07 05:57:59 UTC
RUN_DEPENDS in attachment 199887 [details] will also need updating after update of dependency portname/origin (see bug 233822 comment 1)