Bug 233829 - mail/py-aiosmtpd: Update to 1.2 and add missing atpublic dependency
Summary: mail/py-aiosmtpd: Update to 1.2 and add missing atpublic dependency
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jose Alonso Cardenas Marquez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-06 14:13 UTC by Bernhard Froehlich
Modified: 2018-12-06 14:13 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (acm)


Attachments
py-aiosmtpd 1.2 (1.18 KB, patch)
2018-12-06 14:13 UTC, Bernhard Froehlich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Froehlich freebsd_committer 2018-12-06 14:13:19 UTC
Created attachment 199894 [details]
py-aiosmtpd 1.2

- Update to 1.2
- Add missing atpublic runtime dependency


Without the atpublic dependency you'll get something like that:

Traceback (most recent call last):
  File "mailproxy.py", line 9, in <module>
    from aiosmtpd.controller import Controller
  File "/usr/local/lib/python3.6/site-packages/aiosmtpd/controller.py", line 5, in <module>
    from aiosmtpd.smtp import SMTP
  File "/usr/local/lib/python3.6/site-packages/aiosmtpd/smtp.py", line 10, in <module>
    from public import public
ModuleNotFoundError: No module named 'public'