Bug 233993 - mail/mutt extra patch patches do not apply cleanly if QUOTE_PATCH is not selected
Summary: mail/mutt extra patch patches do not apply cleanly if QUOTE_PATCH is not sele...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-13 21:11 UTC by mjl
Modified: 2018-12-22 16:46 UTC (History)
2 users (show)

See Also:
dereks: maintainer-feedback+


Attachments
remove patch context that prevents building (1.01 KB, patch)
2018-12-13 21:11 UTC, mjl
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mjl 2018-12-13 21:11:18 UTC
Created attachment 200091 [details]
remove patch context that prevents building

I was unable to build mutt, because it failed to apply the extra-patch-ifdef file.  Specifically, the patch is aborting because of the modification in /usr/ports/mail/mutt/files/extra-patch-ifdef to the PATCHES file.

===>  Patching for mutt-1.11.1
===>  Applying extra patch /usr/ports/mail/mutt/files/extra-patch-aspell
===>  Applying extra patch /usr/ports/mail/mutt/files/extra-patch-ifdef
1 out of 1 hunks failed--saving rejects to PATCHES.rej

The issue is that I did not have QUOTE_PATCH configured, so PATCHES did not have the content that the extra-patch-ifdef and extra-patch-reverse_reply patches assumed would be there to apply against.  I think the fix is to remove the patch context, like some of the other patches in mail/mutt/files.

The attached patch works for me, and seems to be similar to the approach taken in revision 474718 for extra-patch-reverse_reply.
Comment 1 Kurt Jaeger freebsd_committer 2018-12-22 16:43:44 UTC
testbuild with/without QUOTE_PATCH selected, looks fine.
Comment 2 Kurt Jaeger freebsd_committer 2018-12-22 16:45:36 UTC
Committed, thanks!
Comment 3 commit-hook freebsd_committer 2018-12-22 16:46:11 UTC
A commit references this bug:

Author: pi
Date: Sat Dec 22 16:45:26 UTC 2018
New revision: 488105
URL: https://svnweb.freebsd.org/changeset/ports/488105

Log:
  mail/mutt: fix extra patches if QUOTE_PATCH is not selected

  - remove some context from the extra-patches so that they
    still apply if QUOTE_PATCH is not selected.

  PR:		233993
  Submitted by:	mjl@luckie.org.nz
  Approved by:	dereks@lifeofadishwasher.com (maintainer)

Changes:
  head/mail/mutt/files/extra-patch-ifdef
  head/mail/mutt/files/extra-patch-reverse_reply