Bug 234068 - net-p2p/jackett: Update to 0.10.518, MAINTAINER
Summary: net-p2p/jackett: Update to 0.10.518, MAINTAINER
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords: easy
Depends on:
Blocks:
 
Reported: 2018-12-16 17:57 UTC by Michiel van Baak
Modified: 2019-04-21 23:20 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
jackett-0.10.518.diff (3.26 KB, patch)
2018-12-16 17:57 UTC, Michiel van Baak
koobs: maintainer-approval+
Details | Diff
portlint log (10.02 KB, text/plain)
2018-12-17 09:03 UTC, Michiel van Baak
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michiel van Baak 2018-12-16 17:57:47 UTC
Created attachment 200161 [details]
jackett-0.10.518.diff

Mainly updates to Indexers, and some log handling changes.
Like with the 0.10.420 version, this one does not start on FreeBSD 12.0, something with kevent() in mono throwing an error.
Did not find the root cause or a fix for that yet, but went to update the port to make some of the trackers working again.

As stated on IRC I also changed the MAINTAINER to myself:

freenode #freebsd:
2018-12-13 12:01:50     koobs   mvanbaak: oh yes, and for your next jackett port, MAINTAINER=you
2018-12-13 12:01:54     koobs   mvanbaak: keep up the good work
Comment 1 kiwi 2018-12-16 19:18:35 UTC
Hi,

Agreed for the bump version and maintainership change :)

Have fun Michiel :)
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-17 05:39:42 UTC
Thank you Michiel,

Can you please confirm this change passes QA (portlint, poudriere)

@Kiwi Thank you for you maintainer efforts!
Comment 3 Michiel van Baak 2018-12-17 09:03:41 UTC
Created attachment 200187 [details]
portlint log

Output of portlint -v
Comment 4 Michiel van Baak 2018-12-17 09:16:55 UTC
* testport OK (poudriere, 11.2-RELEASE-p6, amd64)
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-17 09:24:22 UTC
Comment on attachment 200161 [details]
jackett-0.10.518.diff

Approved by: maintainer <kiwi oav net>
Comment 6 Michiel van Baak 2018-12-17 19:16:41 UTC
(In reply to kiwi from comment #1)

Thanks kiwi. And many thanks for maintaining this.
I'll take good care of the port. promise.
Comment 7 commit-hook freebsd_committer 2018-12-26 22:51:35 UTC
A commit references this bug:

Author: swills
Date: Wed Dec 26 22:51:21 UTC 2018
New revision: 488483
URL: https://svnweb.freebsd.org/changeset/ports/488483

Log:
  net-p2p/jackett: update to 0.10.518

  While here, assign maintainership to submitter

  PR:		234068
  Submitted by:	Michiel van Baak <michiel@vanbaak.eu>
  Approved by:	kiwi@oav.net (maintainer)

Changes:
  head/net-p2p/jackett/Makefile
  head/net-p2p/jackett/distinfo
  head/net-p2p/jackett/pkg-plist
Comment 8 Steve Wills freebsd_committer 2018-12-26 22:52:28 UTC
Committed, thanks!
Comment 9 Loyd Craft 2019-01-23 23:42:49 UTC
Any idea on getting this firing on 12?
Comment 10 Michiel van Baak 2019-01-24 14:20:38 UTC
I think bug #198727 will fix this, but not sure yet.
Didn't have time yet to patch my local mono port to make sure it will fix it.

In three weeks I'll be back home (traveling right now) and I can have a look once back home.
Comment 11 Adonis 2019-04-21 23:20:36 UTC
Any update on this? I am running FreeBSd 12 and cant run jackett because of this issue.