Bug 234070 - devel/qt5: problem with lld and wildcard characters in version scripts
Summary: devel/qt5: problem with lld and wildcard characters in version scripts
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Tijl Coosemans
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2018-12-16 18:37 UTC by Tijl Coosemans
Modified: 2019-01-16 11:17 UTC (History)
5 users (show)

See Also:
antoine: exp-run+


Attachments
qt5-version.patch (2.58 KB, patch)
2018-12-29 13:33 UTC, Tijl Coosemans
no flags Details | Diff
qt5-version.2.patch (5.74 KB, patch)
2019-01-14 21:56 UTC, Tijl Coosemans
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tijl Coosemans freebsd_committer 2018-12-16 18:37:22 UTC
% cat test.c
void
foo( void ) {
}

void
bar( void ) {
}
% cat test.ver
FOO {
	foo*;
};

BAR {
	*;
};
% clang60 -shared test.c -o libtest.so -s -Wl,--version-script=test.ver
tijl@hal:~/tmp/version% readelf -s libtest.so
Symbol table (.dynsym) contains 7 entries:
   Num:    Value          Size Type    Bind   Vis      Ndx Name
     0: 0000000000000000     0 NOTYPE  LOCAL  DEFAULT  UND 
     1: 0000000000000000     0 NOTYPE  WEAK   DEFAULT  UND _Jv_RegisterClasses
     2: 0000000000000000     0 FUNC    WEAK   DEFAULT  UND __cxa_finalize@FBSD_1.0 (4)
     3: 00000000000010dc     0 FUNC    GLOBAL DEFAULT   14 _fini@@BAR (3)
     4: 00000000000010cc     0 FUNC    GLOBAL DEFAULT   13 _init@@BAR (3)
     5: 0000000000001090     6 FUNC    GLOBAL DEFAULT   12 bar@@BAR (3)
     6: 0000000000001080     6 FUNC    GLOBAL DEFAULT   12 foo@@BAR (3)

Note foo@@BAR instead of foo@@FOO.  It's correct when compiling with -fuse-ld=bfd.

This affects the Qt5 ports where many symbols should have a Qt_5_PRIVATE_API version label but have a Qt5 label instead.
Comment 1 Tijl Coosemans freebsd_committer 2018-12-29 13:33:51 UTC
Created attachment 200601 [details]
qt5-version.patch

Quoting https://bugs.llvm.org/show_bug.cgi?id=40176: "If more than one clause in a version script match the same symbol, the last one takes precedence. Thus, if you have the catch-all clause at end (i.e. "*"), it overwrites everything."

This patch for Qt5 changes the version scripts to put the catch-all first.  Note that if this is committed all ports that depend on Qt5 need to be rebuilt because many library symbols will get a different (corrected) version label.
Comment 2 Tijl Coosemans freebsd_committer 2018-12-29 15:59:24 UTC
Assign to kde@ for patch review.
Comment 3 Adriaan de Groot freebsd_committer 2019-01-02 20:45:46 UTC
The patch looks ok. I rebuilt qt5-core with it and noticed that the number of "private" symbols goes up:

```
    [adridg@beastie .../devel/qt5-core]$ for l in /usr/local/lib/qt5/libQt5*.so; do readelf -a $l | grep @Qt_5_PRIVATE; done | wc -l
    4926
    # Rebuild here
    [adridg@beastie .../devel/qt5-core]$ for l in /usr/local/lib/qt5/libQt5*.so; do readelf -a $l | grep @Qt_5_PRIVATE; done | wc -l
    5780
```

But this will need an exp-run (I'm going to leave that to you) and probably a runtime-test (e.g. start some big-ass Qt5 application like www/falkon) as well. And bumps to all the Qt5 ports.
Comment 4 Adriaan de Groot freebsd_committer 2019-01-02 20:46:25 UTC
Assigning back to reporter for a next step.
Comment 5 Tijl Coosemans freebsd_committer 2019-01-12 16:11:00 UTC
Assign to portmgr for exp-run of qt5-* packages and everything that depends on them.  I'll add the port revision bumps right before the commit.  There are too many ports involved and they change too often.
Comment 7 Antoine Brodin freebsd_committer 2019-01-13 22:48:19 UTC
pid 44055 (genManual), uid 0: exited on signal 11 (core dumped)
Comment 8 Tijl Coosemans freebsd_committer 2019-01-14 21:56:30 UTC
Created attachment 201141 [details]
qt5-version.2.patch

The problem was in www/qt5-webengine.  It needs to be rebuilt with this patch.

Older versions of Qt5Webengine exported some memory allocation symbols from the bundled Chromium.  Version 5.9 stopped exporting these [1] but the symbols were kept as weak wrappers for the standard allocation functions to maintain binary compatibility. [2][3]  The problem is that the call to the standard function in these weak wrappers is only resolved to the standard function if there's a call to this standard function in other parts of Qt5Webengine, because only then is there a non-weak symbol that takes precedence over the weak one.  If there's no such non-weak symbol the call in the weak wrapper resolves to the weak wrapper itself creating an infinite tail call loop that overflows the stack and causes a crash.  Some of the allocation functions are variants of C++ new and delete and it probably depends on the compiler whether these variants are used in other parts of Qt5Webengine.

This patch removes the weak wrappers (makes them Linux specific).  This isn't binary compatible but we are already breaking that with the changes to the symbol versions.

[1] https://github.com/qt/qtwebengine/commit/5c2cbfccf9aafb547b0b30914c4056abd25942a4
[2] https://github.com/qt/qtwebengine/commit/2ed5054e3a800fa97c2c9e920ba1e6ea4b6ef2a5
[3] https://github.com/qt/qtwebengine/commit/009f5ebb4bd6e50188671e0815a5dae6afe39db5
Comment 9 Antoine Brodin freebsd_committer 2019-01-15 16:09:24 UTC
Exp-run looks fine
Comment 10 commit-hook freebsd_committer 2019-01-16 11:15:04 UTC
A commit references this bug:

Author: tijl
Date: Wed Jan 16 11:14:06 UTC 2019
New revision: 490472
URL: https://svnweb.freebsd.org/changeset/ports/490472

Log:
  Fix Qt5 symbol version scripts to put the catch-all clause first.  When
  a symbol matches multiple clauses the last one takes precedence.  If the
  catch-all is last it captures everything.  In the case of Qt5 libraries
  this caused all symbols to have a Qt_5 label while some should have
  Qt_5_PRIVATE_API.  This only affects lld because GNU ld always gives the
  catch-all lowest priority.

  Older versions of Qt5Webengine exported some memory allocation symbols from
  the bundled Chromium.  Version 5.9 stopped exporting these [1] but the
  symbols were kept as weak wrappers for the standard allocation functions to
  maintain binary compatibility. [2][3]  The problem is that the call to the
  standard function in these weak wrappers is only resolved to the standard
  function if there's a call to this standard function in other parts of
  Qt5Webengine, because only then is there a non-weak symbol that takes
  precedence over the weak one.  If there's no such non-weak symbol the call
  in the weak wrapper resolves to the weak wrapper itself creating an infinite
  call loop that overflows the stack and causes a crash.  Some of the
  allocation functions are variants of C++ new and delete and it probably
  depends on the compiler whether these variants are used in other parts of
  Qt5Webengine.

  Remove the weak wrappers (make them Linux specific).  This isn't binary
  compatible but we are already breaking that with the changes to the symbol
  versions.

  [1] https://github.com/qt/qtwebengine/commit/5c2cbfccf9aafb547b0b30914c4056abd25942a4
  [2] https://github.com/qt/qtwebengine/commit/2ed5054e3a800fa97c2c9e920ba1e6ea4b6ef2a5
  [3] https://github.com/qt/qtwebengine/commit/009f5ebb4bd6e50188671e0815a5dae6afe39db5

  Bump all ports that depend on Qt5.

  PR:		234070
  Exp-run by:	antoine
  Approved by:	kde (adridg)

Changes:
  head/accessibility/kdeaccessibility/Makefile
  head/accessibility/kmag/Makefile
  head/accessibility/kmousetool/Makefile
  head/accessibility/kmouth/Makefile
  head/accessibility/qt5-speech/Makefile
  head/archivers/ark/Makefile
  head/archivers/kf5-karchive/Makefile
  head/archivers/peazip/Makefile
  head/archivers/quazip/Makefile
  head/astro/gpsbabel/Makefile
  head/astro/kstars/Makefile
  head/astro/libkgeomap/Makefile
  head/astro/marble/Makefile
  head/astro/merkaartor/Makefile
  head/astro/oskar/Makefile
  head/astro/qmapshack/Makefile
  head/astro/stellarium/Makefile
  head/astro/viking/Makefile
  head/audio/abgate-lv2/Makefile
  head/audio/amarok/Makefile
  head/audio/ardour5/Makefile
  head/audio/audiocd-kio/Makefile
  head/audio/bambootracker/Makefile
  head/audio/cadence/Makefile
  head/audio/cantata/Makefile
  head/audio/carla/Makefile
  head/audio/clementine-player/Makefile
  head/audio/csoundqt/Makefile
  head/audio/dpf-plugins-lv2/Makefile
  head/audio/drumkv1-lv2/Makefile
  head/audio/drumstick/Makefile
  head/audio/dsbmixer/Makefile
  head/audio/elisa/Makefile
  head/audio/faustlive/Makefile
  head/audio/flacon/Makefile
  head/audio/fmit/Makefile
  head/audio/guidolib/Makefile
  head/audio/hydrogen/Makefile
  head/audio/jalv/Makefile
  head/audio/jalv-select/Makefile
  head/audio/juk/Makefile
  head/audio/kid3-qt5/Makefile
  head/audio/kmix/Makefile
  head/audio/kwave/Makefile
  head/audio/lastfm-desktop/Makefile
  head/audio/libechonest/Makefile
  head/audio/libkcddb/Makefile
  head/audio/libkcompactdisc/Makefile
  head/audio/lmms/Makefile
  head/audio/midipp/Makefile
  head/audio/minitunes/Makefile
  head/audio/mixxx/Makefile
  head/audio/mixxx21/Makefile
  head/audio/musescore/Makefile
  head/audio/mythplugin-mythmusic/Makefile
  head/audio/padthv1-lv2/Makefile
  head/audio/pavucontrol-qt/Makefile
  head/audio/pc-mixer/Makefile
  head/audio/picard/Makefile
  head/audio/plasma5-plasma-pa/Makefile
  head/audio/polyphone/Makefile
  head/audio/qjackctl/Makefile
  head/audio/qmidiarp/Makefile
  head/audio/qsampler/Makefile
  head/audio/qsynth/Makefile
  head/audio/quimup/Makefile
  head/audio/rosegarden/Makefile
  head/audio/samplv1-lv2/Makefile
  head/audio/sayonara/Makefile
  head/audio/sc3-plugins/Makefile
  head/audio/sonic-visualiser/Makefile
  head/audio/soundkonverter/Makefile
  head/audio/suil/Makefile
  head/audio/supercollider/Makefile
  head/audio/synthv1-lv2/Makefile
  head/audio/vmpk/Makefile
  head/benchmarks/octave-forge-benchmark/Makefile
  head/biology/py-orange3-bioinformatics/Makefile
  head/biology/py-orange3-single-cell/Makefile
  head/biology/ugene/Makefile
  head/cad/freecad/Makefile
  head/cad/fritzing/Makefile
  head/cad/librecad/Makefile
  head/cad/openscad-devel/Makefile
  head/cad/py-pyfda/Makefile
  head/cad/qcad/Makefile
  head/cad/qelectrotech/Makefile
  head/chinese/fcitx-libpinyin/Makefile
  head/chinese/gcin-qt5/Makefile
  head/chinese/qterm/Makefile
  head/comms/cutecom/Makefile
  head/comms/gqrx/Makefile
  head/comms/inspectrum/Makefile
  head/comms/klog/Makefile
  head/comms/libsdr-gui/Makefile
  head/comms/py-qt5-serialport/Makefile
  head/comms/qsstv/Makefile
  head/comms/qt5-connectivity/Makefile
  head/comms/qt5-sensors/Makefile
  head/comms/qt5-serialbus/Makefile
  head/comms/qt5-serialport/Makefile
  head/comms/sdr-wspr/Makefile
  head/comms/ubertooth/Makefile
  head/comms/unixcw/Makefile
  head/comms/wsjtx/Makefile
  head/comms/xcwcp/Makefile
  head/databases/akonadi/Makefile
  head/databases/kbibtex/Makefile
  head/databases/kdb/Makefile
  head/databases/kexi/Makefile
  head/databases/opendbviewer/Makefile
  head/databases/pgmodeler/Makefile
  head/databases/py-qt5-sql/Makefile
  head/databases/qt5-sql/Makefile
  head/databases/qt5-sqldrivers-ibase/Makefile
  head/databases/qt5-sqldrivers-mysql/Makefile
  head/databases/qt5-sqldrivers-odbc/Makefile
  head/databases/qt5-sqldrivers-pgsql/Makefile
  head/databases/qt5-sqldrivers-sqlite2/Makefile
  head/databases/qt5-sqldrivers-sqlite3/Makefile
  head/databases/qt5-sqldrivers-tds/Makefile
  head/databases/redisdesktopmanager/Makefile
  head/databases/sqlitebrowser/Makefile
  head/databases/sqlitestudio/Makefile
  head/deskutils/akonadi-calendar-tools/Makefile
  head/deskutils/akonadi-import-wizard/Makefile
  head/deskutils/akonadiconsole/Makefile
  head/deskutils/akregator/Makefile
  head/deskutils/basket/Makefile
  head/deskutils/calibre/Makefile
  head/deskutils/charmtimetracker/Makefile
  head/deskutils/copyq/Makefile
  head/deskutils/fet/Makefile
  head/deskutils/flameshot/Makefile
  head/deskutils/grantlee-editor/Makefile
  head/deskutils/grantleetheme/Makefile
  head/deskutils/kaddressbook/Makefile
  head/deskutils/kalarm/Makefile
  head/deskutils/kcharselect/Makefile
  head/deskutils/kchmviewer/Makefile
  head/deskutils/kdeconnect-kde/Makefile
  head/deskutils/kdepim/Makefile
  head/deskutils/kdepim-addons/Makefile
  head/deskutils/kdepim-apps-libs/Makefile
  head/deskutils/kdepim-runtime/Makefile
  head/deskutils/keditbookmarks/Makefile
  head/deskutils/kfind/Makefile
  head/deskutils/kmail/Makefile
  head/deskutils/kmail-account-wizard/Makefile
  head/deskutils/knotes/Makefile
  head/deskutils/kontact/Makefile
  head/deskutils/korganizer/Makefile
  head/deskutils/kruler/Makefile
  head/deskutils/latte-dock/Makefile
  head/deskutils/libkdepim/Makefile
  head/deskutils/lumina-archiver/Makefile
  head/deskutils/lumina-calculator/Makefile
  head/deskutils/lumina-fileinfo/Makefile
  head/deskutils/lumina-fm/Makefile
  head/deskutils/lumina-mediaplayer/Makefile
  head/deskutils/lumina-notify/Makefile
  head/deskutils/lumina-pdf/Makefile
  head/deskutils/lumina-screenshot/Makefile
  head/deskutils/lumina-textedit/Makefile
  head/deskutils/lumina-xdg-entry/Makefile
  head/deskutils/lxqt-notificationd/Makefile
  head/deskutils/mbox-importer/Makefile
  head/deskutils/nextcloudclient/Makefile
  head/deskutils/owncloudclient/Makefile
  head/deskutils/pim-data-exporter/Makefile
  head/deskutils/pim-sieve-editor/Makefile
  head/deskutils/pinot/Makefile
  head/deskutils/plasma5-milou/Makefile
  head/deskutils/plasma5-sddm-kcm/Makefile
  head/deskutils/qlipper/Makefile
  head/deskutils/qownnotes/Makefile
  head/deskutils/semantik/Makefile
  head/deskutils/treeline/Makefile
  head/deskutils/zanshin/Makefile
  head/deskutils/znotes/Makefile
  head/devel/RStudio/Makefile
  head/devel/apitrace/Makefile
  head/devel/cervisia/Makefile
  head/devel/cmake-doc/Makefile
  head/devel/cmake-gui/Makefile
  head/devel/cppcheck/Makefile
  head/devel/cppcheck-gui/Makefile
  head/devel/dolphin-plugins/Makefile
  head/devel/eric6/Makefile
  head/devel/fuel/Makefile
  head/devel/grantlee5/Makefile
  head/devel/gwenhywfar-qt5/Makefile
  head/devel/heimdall/Makefile
  head/devel/injeqt/Makefile
  head/devel/kapptemplate/Makefile
  head/devel/kcachegrind/Makefile
  head/devel/kdbg/Makefile
  head/devel/kde-dev-scripts/Makefile
  head/devel/kde-dev-utils/Makefile
  head/devel/kdesdk/Makefile
  head/devel/kdesdk-thumbnailers/Makefile
  head/devel/kdesvn/Makefile
  head/devel/kdev-php/Makefile
  head/devel/kdev-python/Makefile
  head/devel/kdevelop/Makefile
  head/devel/kdevelop-pg-qt/Makefile
  head/devel/kf5-extra-cmake-modules/Makefile
  head/devel/kf5-kapidox/Makefile
  head/devel/kf5-kauth/Makefile
  head/devel/kf5-kbookmarks/Makefile
  head/devel/kf5-kcmutils/Makefile
  head/devel/kf5-kconfig/Makefile
  head/devel/kf5-kcoreaddons/Makefile
  head/devel/kf5-kcrash/Makefile
  head/devel/kf5-kdbusaddons/Makefile
  head/devel/kf5-kdeclarative/Makefile
  head/devel/kf5-kdoctools/Makefile
  head/devel/kf5-kfilemetadata/Makefile
  head/devel/kf5-ki18n/Makefile
  head/devel/kf5-kidletime/Makefile
  head/devel/kf5-kio/Makefile
  head/devel/kf5-kitemmodels/Makefile
  head/devel/kf5-knewstuff/Makefile
  head/devel/kf5-knotifications/Makefile
  head/devel/kf5-knotifyconfig/Makefile
  head/devel/kf5-kpackage/Makefile
  head/devel/kf5-kparts/Makefile
  head/devel/kf5-kpeople/Makefile
  head/devel/kf5-kpty/Makefile
  head/devel/kf5-kservice/Makefile
  head/devel/kf5-ktexteditor/Makefile
  head/devel/kf5-kunitconversion/Makefile
  head/devel/kf5-solid/Makefile
  head/devel/kf5-threadweaver/Makefile
  head/devel/kio-extras/Makefile
  head/devel/libdbusmenu-qt/Makefile
  head/devel/liblxqt/Makefile
  head/devel/liblxqt-l10n/Makefile
  head/devel/libqtxdg/Makefile
  head/devel/liteide/Makefile
  head/devel/lokalize/Makefile
  head/devel/lxqt-build-tools/Makefile
  head/devel/okteta/Makefile
  head/devel/plasma5-khotkeys/Makefile
  head/devel/plasma5-kwrited/Makefile
  head/devel/plasma5-plasma-sdk/Makefile
  head/devel/poxml/Makefile
  head/devel/py-qt5/Makefile
  head/devel/py-qt5-core/Makefile
  head/devel/py-qt5-dbus/Makefile
  head/devel/py-qt5-dbussupport/Makefile
  head/devel/py-qt5-designer/Makefile
  head/devel/py-qt5-designerplugin/Makefile
  head/devel/py-qt5-help/Makefile
  head/devel/py-qt5-qscintilla2/Makefile
  head/devel/py-qt5-test/Makefile
  head/devel/py-qtconsole/Makefile
  head/devel/py-spyder/Makefile
  head/devel/pyotherside-qt5/Makefile
  head/devel/pyside/Makefile
  head/devel/pyside-tools/Makefile
  head/devel/qbs/Makefile
  head/devel/qca/Makefile
  head/devel/qgit/Makefile
  head/devel/qjson/Makefile
  head/devel/qscintilla2-designerplugin-qt5/Makefile
  head/devel/qscintilla2-qt5/Makefile
  head/devel/qt-maybe/Makefile
  head/devel/qt5/Makefile
  head/devel/qt5/files/extrapatch-mkspecs_features_qt__module.prf
  head/devel/qt5-assistant/Makefile
  head/devel/qt5-buildtools/Makefile
  head/devel/qt5-concurrent/Makefile
  head/devel/qt5-core/Makefile
  head/devel/qt5-dbus/Makefile
  head/devel/qt5-designer/Makefile
  head/devel/qt5-help/Makefile
  head/devel/qt5-linguist/Makefile
  head/devel/qt5-linguisttools/Makefile
  head/devel/qt5-location/Makefile
  head/devel/qt5-qdbus/Makefile
  head/devel/qt5-qdbusviewer/Makefile
  head/devel/qt5-qdoc/Makefile
  head/devel/qt5-qmake/Makefile
  head/devel/qt5-remoteobjects/Makefile
  head/devel/qt5-script/Makefile
  head/devel/qt5-scripttools/Makefile
  head/devel/qt5-scxml/Makefile
  head/devel/qt5-testlib/Makefile
  head/devel/qt5-uitools/Makefile
  head/devel/qtcreator/Makefile
  head/devel/qtscriptgenerator/Makefile
  head/devel/sasm/Makefile
  head/devel/svn2git/Makefile
  head/devel/tortoisehg/Makefile
  head/devel/umbrello/Makefile
  head/devel/vitables/Makefile
  head/devel/zeal/Makefile
  head/dns/kf5-kdnssd/Makefile
  head/dns/qmdnsengine/Makefile
  head/editors/calligra/Makefile
  head/editors/calligraplan/Makefile
  head/editors/dexed/Makefile
  head/editors/encryptpad/Makefile
  head/editors/featherpad/Makefile
  head/editors/focuswriter/Makefile
  head/editors/ghostwriter/Makefile
  head/editors/kate/Makefile
  head/editors/kile/Makefile
  head/editors/lazarus-qt5/Makefile
  head/editors/neovim-qt/Makefile
  head/editors/picpas/Makefile
  head/editors/tea/Makefile
  head/editors/texmaker/Makefile
  head/editors/texstudio/Makefile
  head/editors/texworks/Makefile
  head/emulators/aqemu/Makefile
  head/emulators/citra-qt5/Makefile
  head/emulators/dolphin-emu/Makefile
  head/emulators/fs-uae-launcher/Makefile
  head/emulators/loemu/Makefile
  head/emulators/mame/Makefile
  head/emulators/mgba/Makefile
  head/emulators/mupen64plus-qt/Makefile
  head/emulators/ppsspp-qt5/Makefile
  head/emulators/qmc2/Makefile
  head/emulators/rpcs3/Makefile
  head/emulators/vboxtool/Makefile
  head/emulators/virtualbox-ose/Makefile
  head/emulators/yabause/Makefile
  head/finance/alkimia/Makefile
  head/finance/electrum/Makefile
  head/finance/kmymoney/Makefile
  head/finance/qtbitcointrader/Makefile
  head/finance/skrooge/Makefile
  head/games/2048-qt/Makefile
  head/games/auralquiz/Makefile
  head/games/blinken/Makefile
  head/games/bomber/Makefile
  head/games/bovo/Makefile
  head/games/chessx/Makefile
  head/games/cockatrice/Makefile
  head/games/colorcode/Makefile
  head/games/connectagram/Makefile
  head/games/cutemaze/Makefile
  head/games/doomsday/Makefile
  head/games/dustrac/Makefile
  head/games/flightgear/Makefile
  head/games/gcompris-qt/Makefile
  head/games/gottet/Makefile
  head/games/granatier/Makefile
  head/games/hedgewars/Makefile
  head/games/hexalate/Makefile
  head/games/kanagram/Makefile
  head/games/kapman/Makefile
  head/games/katomic/Makefile
  head/games/kblackbox/Makefile
  head/games/kblocks/Makefile
  head/games/kbounce/Makefile
  head/games/kbreakout/Makefile
  head/games/kdegames/Makefile
  head/games/kdiamond/Makefile
  head/games/kfourinline/Makefile
  head/games/kgoldrunner/Makefile
  head/games/khangman/Makefile
  head/games/kigo/Makefile
  head/games/killbots/Makefile
  head/games/kiriki/Makefile
  head/games/kjumpingcube/Makefile
  head/games/klickety/Makefile
  head/games/klines/Makefile
  head/games/kmahjongg/Makefile
  head/games/kmines/Makefile
  head/games/knavalbattle/Makefile
  head/games/knetwalk/Makefile
  head/games/knights/Makefile
  head/games/kolf/Makefile
  head/games/kollision/Makefile
  head/games/konquest/Makefile
  head/games/kpat/Makefile
  head/games/kreversi/Makefile
  head/games/kshisen/Makefile
  head/games/ksirk/Makefile
  head/games/ksnakeduel/Makefile
  head/games/kspaceduel/Makefile
  head/games/ksquares/Makefile
  head/games/ksudoku/Makefile
  head/games/ktuberling/Makefile
  head/games/kubrick/Makefile
  head/games/libkdegames/Makefile
  head/games/libkmahjongg/Makefile
  head/games/lskat/Makefile
  head/games/multimc/Makefile
  head/games/openage/Makefile
  head/games/openmw/Makefile
  head/games/palapeli/Makefile
  head/games/peg-e/Makefile
  head/games/pentobi/Makefile
  head/games/picmi/Makefile
  head/games/py-mnemosyne/Makefile
  head/games/qnetwalk/Makefile
  head/games/simsu/Makefile
  head/games/solarus/Makefile
  head/games/solarus-quest-editor/Makefile
  head/games/tanglet/Makefile
  head/games/tetzle/Makefile
  head/games/warzone2100/Makefile
  head/graphics/cloudcompare/Makefile
  head/graphics/colmap/Makefile
  head/graphics/converseen/Makefile
  head/graphics/diffpdf/Makefile
  head/graphics/digikam/Makefile
  head/graphics/dilay/Makefile
  head/graphics/djview4/Makefile
  head/graphics/drawpile/Makefile
  head/graphics/dspdfviewer/Makefile
  head/graphics/engauge-digitizer/Makefile
  head/graphics/evolvotron/Makefile
  head/graphics/fracplanet/Makefile
  head/graphics/fraqtive/Makefile
  head/graphics/gmic-qt/Makefile
  head/graphics/gpxsee/Makefile
  head/graphics/gwenview/Makefile
  head/graphics/impressive/Makefile
  head/graphics/ipe/Makefile
  head/graphics/kamera/Makefile
  head/graphics/kcolorchooser/Makefile
  head/graphics/kdegraphics/Makefile
  head/graphics/kdegraphics-mobipocket/Makefile
  head/graphics/kdegraphics-svgpart/Makefile
  head/graphics/kdegraphics-thumbnailers/Makefile
  head/graphics/kdiagram/Makefile
  head/graphics/kf5-kimageformats/Makefile
  head/graphics/kf5-kplotting/Makefile
  head/graphics/kf5-prison/Makefile
  head/graphics/kgraphviewer/Makefile
  head/graphics/kimagemapeditor/Makefile
  head/graphics/kipiplugins/Makefile
  head/graphics/klatexformula/Makefile
  head/graphics/kolourpaint/Makefile
  head/graphics/kphotoalbum/Makefile
  head/graphics/krita/Makefile
  head/graphics/lazpaint/Makefile
  head/graphics/libQGLViewer/Makefile
  head/graphics/libkdcraw/Makefile
  head/graphics/libkexiv2/Makefile
  head/graphics/libkipi/Makefile
  head/graphics/libksane/Makefile
  head/graphics/libprojectm/Makefile
  head/graphics/luminance-qt5/Makefile
  head/graphics/lximage-qt/Makefile
  head/graphics/lximageqt-l10n/Makefile
  head/graphics/mandelbulber/Makefile
  head/graphics/natron/Makefile
  head/graphics/nomacs/Makefile
  head/graphics/okular/Makefile
  head/graphics/opencsg/Makefile
  head/graphics/openorienteering-mapper/Makefile
  head/graphics/pencil2d/Makefile
  head/graphics/photivo/Makefile
  head/graphics/photoqt/Makefile
  head/graphics/phototonic/Makefile
  head/graphics/poppler-qt5/Makefile
  head/graphics/py-python-poppler-qt5/Makefile
  head/graphics/py-qt5-svg/Makefile
  head/graphics/qcomicbook/Makefile
  head/graphics/qgis/Makefile
  head/graphics/qt5-3d/Makefile
  head/graphics/qt5-graphicaleffects/Makefile
  head/graphics/qt5-imageformats/Makefile
  head/graphics/qt5-opengl/Makefile
  head/graphics/qt5-pixeltool/Makefile
  head/graphics/qt5-svg/Makefile
  head/graphics/qt5-wayland/Makefile
  head/graphics/qtawesome/Makefile
  head/graphics/qtpbfimageplugin/Makefile
  head/graphics/radiance/Makefile
  head/graphics/showimage/Makefile
  head/graphics/skanlite/Makefile
  head/graphics/spectacle/Makefile
  head/graphics/tiled/Makefile
  head/graphics/vv/Makefile
  head/graphics/xpdf4/Makefile
  head/graphics/zint/Makefile
  head/irc/dxirc/Makefile
  head/irc/konversation/Makefile
  head/irc/kvirc/Makefile
  head/irc/quassel/Makefile
  head/japanese/fcitx-mozc/Makefile
  head/japanese/fcitx-skk/Makefile
  head/japanese/ibus-mozc/Makefile
  head/japanese/kiten/Makefile
  head/japanese/mozc-server/Makefile
  head/japanese/mozc-tool/Makefile
  head/japanese/uim-mozc/Makefile
  head/japanese/xpdf/Makefile
  head/korean/xpdf/Makefile
  head/lang/basic256/Makefile
  head/lang/kf5-kross/Makefile
  head/lang/kross-interpreters/Makefile
  head/lang/kturtle/Makefile
  head/lang/py-qt5-qml/Makefile
  head/mail/trojita/Makefile
  head/math/analitza/Makefile
  head/math/cantor/Makefile
  head/math/convertall/Makefile
  head/math/dynare/Makefile
  head/math/g2o/Makefile
  head/math/kalgebra/Makefile
  head/math/kbruch/Makefile
  head/math/kcalc/Makefile
  head/math/kig/Makefile
  head/math/kmplot/Makefile
  head/math/labplot/Makefile
  head/math/mathgl/Makefile
  head/math/mathmod/Makefile
  head/math/octave/Makefile
  head/math/octave-forge/Makefile
  head/math/octave-forge-actuarial/Makefile
  head/math/octave-forge-base/Makefile
  head/math/octave-forge-bim/Makefile
  head/math/octave-forge-bioinfo/Makefile
  head/math/octave-forge-bsltl/Makefile
  head/math/octave-forge-cgi/Makefile
  head/math/octave-forge-civil-engineering/Makefile
  head/math/octave-forge-control/Makefile
  head/math/octave-forge-data-smoothing/Makefile
  head/math/octave-forge-database/Makefile
  head/math/octave-forge-dataframe/Makefile
  head/math/octave-forge-dicom/Makefile
  head/math/octave-forge-divand/Makefile
  head/math/octave-forge-doctest/Makefile
  head/math/octave-forge-econometrics/Makefile
  head/math/octave-forge-fenv/Makefile
  head/math/octave-forge-financial/Makefile
  head/math/octave-forge-fits/Makefile
  head/math/octave-forge-fpl/Makefile
  head/math/octave-forge-fuzzy-logic-toolkit/Makefile
  head/math/octave-forge-ga/Makefile
  head/math/octave-forge-general/Makefile
  head/math/octave-forge-generate_html/Makefile
  head/math/octave-forge-geometry/Makefile
  head/math/octave-forge-gnuplot/Makefile
  head/math/octave-forge-gsl/Makefile
  head/math/octave-forge-ident/Makefile
  head/math/octave-forge-image/Makefile
  head/math/octave-forge-informationtheory/Makefile
  head/math/octave-forge-integration/Makefile
  head/math/octave-forge-interval/Makefile
  head/math/octave-forge-io/Makefile
  head/math/octave-forge-irsa/Makefile
  head/math/octave-forge-level-set/Makefile
  head/math/octave-forge-linear-algebra/Makefile
  head/math/octave-forge-lssa/Makefile
  head/math/octave-forge-ltfat/Makefile
  head/math/octave-forge-mapping/Makefile
  head/math/octave-forge-mechanics/Makefile
  head/math/octave-forge-miscellaneous/Makefile
  head/math/octave-forge-missing-functions/Makefile
  head/math/octave-forge-msh/Makefile
  head/math/octave-forge-multicore/Makefile
  head/math/octave-forge-mvn/Makefile
  head/math/octave-forge-nan/Makefile
  head/math/octave-forge-ncarray/Makefile
  head/math/octave-forge-netcdf/Makefile
  head/math/octave-forge-nlwing2/Makefile
  head/math/octave-forge-nnet/Makefile
  head/math/octave-forge-nurbs/Makefile
  head/math/octave-forge-oct2mat/Makefile
  head/math/octave-forge-octclip/Makefile
  head/math/octave-forge-octproj/Makefile
  head/math/octave-forge-odebvp/Makefile
  head/math/octave-forge-optics/Makefile
  head/math/octave-forge-optim/Makefile
  head/math/octave-forge-optiminterp/Makefile
  head/math/octave-forge-outliers/Makefile
  head/math/octave-forge-parallel/Makefile
  head/math/octave-forge-plot/Makefile
  head/math/octave-forge-quaternion/Makefile
  head/math/octave-forge-queueing/Makefile
  head/math/octave-forge-secs1d/Makefile
  head/math/octave-forge-secs2d/Makefile
  head/math/octave-forge-secs3d/Makefile
  head/math/octave-forge-signal/Makefile
  head/math/octave-forge-simp/Makefile
  head/math/octave-forge-sockets/Makefile
  head/math/octave-forge-sparsersb/Makefile
  head/math/octave-forge-specfun/Makefile
  head/math/octave-forge-special-matrix/Makefile
  head/math/octave-forge-splines/Makefile
  head/math/octave-forge-statistics/Makefile
  head/math/octave-forge-stk/Makefile
  head/math/octave-forge-strings/Makefile
  head/math/octave-forge-struct/Makefile
  head/math/octave-forge-symband/Makefile
  head/math/octave-forge-symbolic/Makefile
  head/math/octave-forge-tcl-octave/Makefile
  head/math/octave-forge-tisean/Makefile
  head/math/octave-forge-tsa/Makefile
  head/math/octave-forge-video/Makefile
  head/math/octave-forge-zenity/Makefile
  head/math/octave-forge-zeromq/Makefile
  head/math/octomap/Makefile
  head/math/openmesh/Makefile
  head/math/qtoctave/Makefile
  head/math/qwtplot3d/Makefile
  head/math/rkward-kde/Makefile
  head/math/rocs/Makefile
  head/math/rpcalc/Makefile
  head/math/speedcrunch/Makefile
  head/math/vtk8/Makefile
  head/math/zegrapher/Makefile
  head/misc/actiona/Makefile
  head/misc/artikulate/Makefile
  head/misc/bibletime/Makefile
  head/misc/crosti/Makefile
  head/misc/kde-thumbnailer-chm/Makefile
  head/misc/kde-thumbnailer-epub/Makefile
  head/misc/kde-thumbnailer-fb2/Makefile
  head/misc/kdeedu/Makefile
  head/misc/kdeedu-data/Makefile
  head/misc/kdeutils/Makefile
  head/misc/kf5-purpose/Makefile
  head/misc/kgeography/Makefile
  head/misc/klettres/Makefile
  head/misc/ktouch/Makefile
  head/misc/kwordquiz/Makefile
  head/misc/libkeduvocdocument/Makefile
  head/misc/molequeue/Makefile
  head/misc/openmvg/Makefile
  head/misc/orange3/Makefile
  head/misc/parley/Makefile
  head/misc/py-QSpectrumAnalyzer/Makefile
  head/misc/py-orange3-associate/Makefile
  head/misc/py-orange3-datafusion/Makefile
  head/misc/py-orange3-educational/Makefile
  head/misc/py-orange3-network/Makefile
  head/misc/py-orange3-timeseries/Makefile
  head/misc/py-qt5-demo/Makefile
  head/misc/qbrew/Makefile
  head/misc/qt5-l10n/Makefile
  head/misc/qt5ct/Makefile
  head/misc/saaghar/Makefile
  head/misc/tellico/Makefile
  head/misc/urh/Makefile
  head/misc/valentina/Makefile
  head/misc/zygrib/Makefile
  head/misc/zygrib-maps/Makefile
  head/multimedia/QtAV/Makefile
  head/multimedia/baka-mplayer/Makefile
  head/multimedia/bino/Makefile
  head/multimedia/cinelerra-gg/Makefile
  head/multimedia/clipgrab/Makefile
  head/multimedia/dragon/Makefile
  head/multimedia/dvbcut/Makefile
  head/multimedia/fpc-libvlc/Makefile
  head/multimedia/gstreamer1-qt/Makefile
  head/multimedia/iso2mkv/Makefile
  head/multimedia/kaffeine/Makefile
  head/multimedia/kamoso/Makefile
  head/multimedia/kdemultimedia/Makefile
  head/multimedia/kdemultimedia-ffmpegthumbs/Makefile
  head/multimedia/kdenlive/Makefile
  head/multimedia/kf5-kmediaplayer/Makefile
  head/multimedia/kmplayer/Makefile
  head/multimedia/lives/Makefile
  head/multimedia/mediadownloader/Makefile
  head/multimedia/minitube/Makefile
  head/multimedia/mkvtoolnix/Makefile
  head/multimedia/mlt-qt5/Makefile
  head/multimedia/mpc-qt/Makefile
  head/multimedia/mythtv/Makefile
  head/multimedia/mythtv-frontend/Makefile
  head/multimedia/obs-qtwebkit/Makefile
  head/multimedia/obs-studio/Makefile
  head/multimedia/phonon/Makefile
  head/multimedia/phonon-designerplugin/Makefile
  head/multimedia/phonon-gstreamer/Makefile
  head/multimedia/phonon-vlc/Makefile
  head/multimedia/phonon-xine/Makefile
  head/multimedia/py-PySceneDetect/Makefile
  head/multimedia/py-openlp/Makefile
  head/multimedia/py-qt5-multimedia/Makefile
  head/multimedia/py-qt5-multimediawidgets/Makefile
  head/multimedia/qmmp/Makefile
  head/multimedia/qmmp-plugin-pack/Makefile
  head/multimedia/qmmp-plugin-pack-qt5/Makefile
  head/multimedia/qmmp-qt5/Makefile
  head/multimedia/qt5-multimedia/Makefile
  head/multimedia/shotcut/Makefile
  head/multimedia/simplescreenrecorder/Makefile
  head/multimedia/smplayer/Makefile
  head/multimedia/smtube/Makefile
  head/multimedia/subtitlecomposer/Makefile
  head/multimedia/syncplay/Makefile
  head/multimedia/vlc/Makefile
  head/multimedia/webcamoid/Makefile
  head/multimedia/webvfx-qt5/Makefile
  head/net/akonadi-calendar/Makefile
  head/net/akonadi-contacts/Makefile
  head/net/akonadi-mime/Makefile
  head/net/akonadi-notes/Makefile
  head/net/akonadi-search/Makefile
  head/net/avahi-qt5/Makefile
  head/net/calendarsupport/Makefile
  head/net/eventviews/Makefile
  head/net/incidenceeditor/Makefile
  head/net/kalarmcal/Makefile
  head/net/kblog/Makefile
  head/net/kcalcore/Makefile
  head/net/kcalutils/Makefile
  head/net/kcontacts/Makefile
  head/net/kdav/Makefile
  head/net/kdenetwork/Makefile
  head/net/kdenetwork-filesharing/Makefile
  head/net/kf5-kholidays/Makefile
  head/net/kf5-kxmlrpcclient/Makefile
  head/net/kf5-syndication/Makefile
  head/net/kget/Makefile
  head/net/kidentitymanagement/Makefile
  head/net/kimap/Makefile
  head/net/kio-gdrive/Makefile
  head/net/kitinerary/Makefile
  head/net/kldap/Makefile
  head/net/kmailtransport/Makefile
  head/net/kmbox/Makefile
  head/net/kmime/Makefile
  head/net/kontactinterface/Makefile
  head/net/kpimtextedit/Makefile
  head/net/krdc/Makefile
  head/net/krfb/Makefile
  head/net/ksmtp/Makefile
  head/net/ktnef/Makefile
  head/net/libgravatar/Makefile
  head/net/libkgapi/Makefile
  head/net/libksieve/Makefile
  head/net/libkvkontakte/Makefile
  head/net/libmaia/Makefile
  head/net/libmediawiki/Makefile
  head/net/libproxy-kde/Makefile
  head/net/linphone/Makefile
  head/net/mailcommon/Makefile
  head/net/mailimporter/Makefile
  head/net/messagelib/Makefile
  head/net/nitroshare/Makefile
  head/net/pimcommon/Makefile
  head/net/py-qt5-network/Makefile
  head/net/qoauth/Makefile
  head/net/qoauth-qt5/Makefile
  head/net/qt5-network/Makefile
  head/net/qt5-networkauth/Makefile
  head/net/qtweetlib/Makefile
  head/net/quiterss/Makefile
  head/net/spoofer/Makefile
  head/net/wireshark-qt5/Makefile
  head/net/wpa_supplicant_gui/Makefile
  head/net/zeroconf-ioslave/Makefile
  head/net-im/cutegram/Makefile
  head/net-im/diligent/Makefile
  head/net-im/gitterdone/Makefile
  head/net-im/kaccounts-integration/Makefile
  head/net-im/kaccounts-providers/Makefile
  head/net-im/kde-telepathy/Makefile
  head/net-im/kopete/Makefile
  head/net-im/ktp-accounts-kcm/Makefile
  head/net-im/ktp-approver/Makefile
  head/net-im/ktp-auth-handler/Makefile
  head/net-im/ktp-call-ui/Makefile
  head/net-im/ktp-common-internals/Makefile
  head/net-im/ktp-contact-list/Makefile
  head/net-im/ktp-contact-runner/Makefile
  head/net-im/ktp-desktop-applets/Makefile
  head/net-im/ktp-filetransfer-handler/Makefile
  head/net-im/ktp-kded-module/Makefile
  head/net-im/ktp-send-file/Makefile
  head/net-im/ktp-text-ui/Makefile
  head/net-im/libaccounts-qt5/Makefile
  head/net-im/libjreen/Makefile
  head/net-im/libqtelegram-ae/Makefile
  head/net-im/libsignon-glib/Makefile
  head/net-im/licq-osd/Makefile
  head/net-im/licq-qt-gui/Makefile
  head/net-im/psi/Makefile
  head/net-im/qTox/Makefile
  head/net-im/qxmpp/Makefile
  head/net-im/qxmpp-qt5/Makefile
  head/net-im/ricochet/Makefile
  head/net-im/scudcloud/Makefile
  head/net-im/teamwords/Makefile
  head/net-im/telegram-desktop/Makefile
  head/net-im/telegramqml/Makefile
  head/net-im/telepathy-accounts-signon/Makefile
  head/net-im/telepathy-logger-qt5/Makefile
  head/net-im/telepathy-qt/Makefile
  head/net-im/turpial/Makefile
  head/net-mgmt/nagstamon/Makefile
  head/net-mgmt/onionlauncher/Makefile
  head/net-mgmt/seafile-gui/Makefile
  head/net-p2p/awgg/Makefile
  head/net-p2p/bitcoin/Makefile
  head/net-p2p/ktorrent/Makefile
  head/net-p2p/libktorrent/Makefile
  head/net-p2p/litecoin/Makefile
  head/net-p2p/namecoin/Makefile
  head/net-p2p/qbittorrent/Makefile
  head/net-p2p/qtum/Makefile
  head/net-p2p/retroshare/Makefile
  head/net-p2p/torrent-file-editor/Makefile
  head/net-p2p/transmission/Makefile
  head/net-p2p/transmission-qt/Makefile
  head/net-p2p/transmission-remote-gui/Makefile
  head/net-p2p/tribler/Makefile
  head/polish/kadu/Makefile
  head/polish/qnapi/Makefile
  head/ports-mgmt/octopkg/Makefile
  head/ports-mgmt/portrac/Makefile
  head/print/frescobaldi/Makefile
  head/print/hplip/Makefile
  head/print/hplip-plugin/Makefile
  head/print/lyx/Makefile
  head/print/print-manager/Makefile
  head/print/py-qt5-printsupport/Makefile
  head/print/qpdfview/Makefile
  head/print/qt5-printsupport/Makefile
  head/print/scribus-devel/Makefile
  head/russian/emkatic/Makefile
  head/science/avogadro2/Makefile
  head/science/avogadrolibs/Makefile
  head/science/code_saturne/Makefile
  head/science/iboview/Makefile
  head/science/kalzium/Makefile
  head/science/kst2/Makefile
  head/science/liggghts/Makefile
  head/science/molsketch/Makefile
  head/science/paraview/Makefile
  head/science/pulseview/Makefile
  head/science/py-avogadrolibs/Makefile
  head/science/py-pymol/Makefile
  head/science/scidavis/Makefile
  head/science/step/Makefile
  head/science/vipster/Makefile
  head/science/xdrawchem/Makefile
  head/security/fwbuilder/Makefile
  head/security/gpgme-qt5/Makefile
  head/security/keepassx-devel/Makefile
  head/security/keepassxc/Makefile
  head/security/kf5-kdesu/Makefile
  head/security/kgpg/Makefile
  head/security/kleopatra/Makefile
  head/security/kpkpass/Makefile
  head/security/kwalletmanager/Makefile
  head/security/libkleo/Makefile
  head/security/lxqt-openssh-askpass/Makefile
  head/security/lxqt-sudo/Makefile
  head/security/openconnect-gui/Makefile
  head/security/pinentry-qt5/Makefile
  head/security/plasma5-kscreenlocker/Makefile
  head/security/plasma5-ksshaskpass/Makefile
  head/security/plasma5-kwallet-pam/Makefile
  head/security/qtkeychain/Makefile
  head/security/xca/Makefile
  head/security/yubikey-manager-qt/Makefile
  head/security/yubikey-personalization-gui/Makefile
  head/security/yubikey-piv-manager/Makefile
  head/security/yubioath-desktop/Makefile
  head/sysutils/UEFITool/Makefile
  head/sysutils/android-file-transfer-qt5/Makefile
  head/sysutils/baloo-widgets/Makefile
  head/sysutils/bsdisks/Makefile
  head/sysutils/dsbbatmon/Makefile
  head/sysutils/dsblogoutmgr/Makefile
  head/sysutils/filelight/Makefile
  head/sysutils/glogg/Makefile
  head/sysutils/k3b/Makefile
  head/sysutils/kbackup/Makefile
  head/sysutils/kcron/Makefile
  head/sysutils/kdeadmin/Makefile
  head/sysutils/kdebugsettings/Makefile
  head/sysutils/kdf/Makefile
  head/sysutils/kdialog/Makefile
  head/sysutils/kdirstat/Makefile
  head/sysutils/kf5-baloo/Makefile
  head/sysutils/kf5-kwallet/Makefile
  head/sysutils/kfloppy/Makefile
  head/sysutils/khelpcenter/Makefile
  head/sysutils/krename/Makefile
  head/sysutils/kshutdown/Makefile
  head/sysutils/ksystemlog/Makefile
  head/sysutils/libsysstat/Makefile
  head/sysutils/luckybackup/Makefile
  head/sysutils/lxqt-admin/Makefile
  head/sysutils/lxqt-config/Makefile
  head/sysutils/lxqt-policykit/Makefile
  head/sysutils/lxqt-qtplugin/Makefile
  head/sysutils/pc-networkmanager/Makefile
  head/sysutils/pcbsd-appweb/Makefile
  head/sysutils/pcbsd-syscache/Makefile
  head/sysutils/pcbsd-utils/Makefile
  head/sysutils/pcbsd-utils-qt5/Makefile
  head/sysutils/plasma-pass/Makefile
  head/sysutils/plasma5-discover/Makefile
  head/sysutils/plasma5-drkonqi/Makefile
  head/sysutils/plasma5-kde-cli-tools/Makefile
  head/sysutils/plasma5-kinfocenter/Makefile
  head/sysutils/plasma5-kmenuedit/Makefile
  head/sysutils/plasma5-ksysguard/Makefile
  head/sysutils/plasma5-libksysguard/Makefile
  head/sysutils/plasma5-polkit-kde-agent-1/Makefile
  head/sysutils/plasma5-powerdevil/Makefile
  head/sysutils/plasma5-systemsettings/Makefile
  head/sysutils/plasma5-user-manager/Makefile
  head/sysutils/polkit-qt/Makefile
  head/sysutils/qdirstat/Makefile
  head/sysutils/qsudo/Makefile
  head/sysutils/qt5-qtdiag/Makefile
  head/sysutils/qt5-qtpaths/Makefile
  head/sysutils/qt5-qtplugininfo/Makefile
  head/sysutils/qtpass/Makefile
  head/sysutils/signon-kwallet-extension/Makefile
  head/sysutils/signon-plugin-oauth2/Makefile
  head/sysutils/signon-qt5/Makefile
  head/sysutils/signon-ui/Makefile
  head/sysutils/sweeper/Makefile
  head/sysutils/sysadm/Makefile
  head/sysutils/sysadm-client/Makefile
  head/sysutils/tarsnap-gui/Makefile
  head/sysutils/trueos-libqt5/Makefile
  head/sysutils/twmn/Makefile
  head/sysutils/vzvol/Makefile
  head/textproc/dikt/Makefile
  head/textproc/fcitx-qt5/Makefile
  head/textproc/goldendict/Makefile
  head/textproc/kdiff3/Makefile
  head/textproc/kf5-kcodecs/Makefile
  head/textproc/kf5-sonnet/Makefile
  head/textproc/kf5-syntax-highlighting/Makefile
  head/textproc/kompare/Makefile
  head/textproc/kreport/Makefile
  head/textproc/libkomparediff2/Makefile
  head/textproc/py-orange3-text/Makefile
  head/textproc/py-qt5-xml/Makefile
  head/textproc/py-qt5-xmlpatterns/Makefile
  head/textproc/qt5-xml/Makefile
  head/textproc/qt5-xmlpatterns/Makefile
  head/textproc/retext/Makefile
  head/textproc/sigil/Makefile
  head/textproc/uim/Makefile
  head/textproc/uim-qt5/Makefile
  head/www/choqok/Makefile
  head/www/cutelyst/Makefile
  head/www/falkon/Makefile
  head/www/kf5-kdewebkit/Makefile
  head/www/kf5-khtml/Makefile
  head/www/kf5-kjs/Makefile
  head/www/kf5-kjsembed/Makefile
  head/www/onionshare/Makefile
  head/www/otter-browser/Makefile
  head/www/plasma5-plasma-browser-integration/Makefile
  head/www/py-qt5-webchannel/Makefile
  head/www/py-qt5-webengine/Makefile
  head/www/py-qt5-webkit/Makefile
  head/www/py-qt5-webkitwidgets/Makefile
  head/www/qhttpengine/Makefile
  head/www/qt5-webchannel/Makefile
  head/www/qt5-webengine/Makefile
  head/www/qt5-webengine/files/patch-src_core_api_core_api.pro
  head/www/qt5-webengine/files/patch-src_core_api_qtbug-61521.cpp
  head/www/qt5-webkit/Makefile
  head/www/qt5-websockets/Makefile
  head/www/qt5-websockets-qml/Makefile
  head/www/qt5-webview/Makefile
  head/www/qupzilla-qt5/Makefile
  head/www/qutebrowser/Makefile
  head/x11/antimicro/Makefile
  head/x11/compton-conf/Makefile
  head/x11/cool-retro-term/Makefile
  head/x11/dsbautostart/Makefile
  head/x11/kde-baseapps/Makefile
  head/x11/kde5/Makefile
  head/x11/kf5-frameworkintegration/Makefile
  head/x11/kf5-frameworks/Makefile
  head/x11/kf5-kactivities/Makefile
  head/x11/kf5-kactivities-stats/Makefile
  head/x11/kf5-kded/Makefile
  head/x11/kf5-kdelibs4support/Makefile
  head/x11/kf5-kglobalaccel/Makefile
  head/x11/kf5-kinit/Makefile
  head/x11/kf5-krunner/Makefile
  head/x11/kf5-kwayland/Makefile
  head/x11/kf5-kwindowsystem/Makefile
  head/x11/kf5-plasma-framework/Makefile
  head/x11/konsole/Makefile
  head/x11/leechcraft/Makefile
  head/x11/libfm-qt/Makefile
  head/x11/libfmqt-l10n/Makefile
  head/x11/lumina/Makefile
  head/x11/lumina-core/Makefile
  head/x11/lumina-coreutils/Makefile
  head/x11/lxqt-about/Makefile
  head/x11/lxqt-globalkeys/Makefile
  head/x11/lxqt-globalkeys-l10n/Makefile
  head/x11/lxqt-l10n/Makefile
  head/x11/lxqt-runner/Makefile
  head/x11/pcdm/Makefile
  head/x11/plasma5-kactivitymanagerd/Makefile
  head/x11/plasma5-kgamma5/Makefile
  head/x11/plasma5-kscreen/Makefile
  head/x11/plasma5-kwayland-integration/Makefile
  head/x11/plasma5-libkscreen/Makefile
  head/x11/plasma5-plasma/Makefile
  head/x11/plasma5-plasma-desktop/Makefile
  head/x11/plasma5-plasma-integration/Makefile
  head/x11/plasma5-plasma-workspace/Makefile
  head/x11/py-qt5-opengl/Makefile
  head/x11/qt5-qev/Makefile
  head/x11/qt5-x11extras/Makefile
  head/x11/qterminal/Makefile
  head/x11/qterminal-l10n/Makefile
  head/x11/radare-cutter/Makefile
  head/x11/rsibreak/Makefile
  head/x11/sddm/Makefile
  head/x11/yakuake/Makefile
  head/x11-clocks/kteatime/Makefile
  head/x11-clocks/ktimer/Makefile
  head/x11-fm/dolphin/Makefile
  head/x11-fm/konqueror/Makefile
  head/x11-fm/krusader2/Makefile
  head/x11-fm/pcmanfm-qt/Makefile
  head/x11-fm/pcmanfmqt-l10n/Makefile
  head/x11-fm/ultracopier/Makefile
  head/x11-themes/Kvantum/Makefile
  head/x11-themes/adwaita-qt/Makefile
  head/x11-themes/kf5-breeze-icons/Makefile
  head/x11-themes/kf5-kemoticons/Makefile
  head/x11-themes/kf5-kiconthemes/Makefile
  head/x11-themes/kf5-oxygen-icons5/Makefile
  head/x11-themes/kf5-qqc2-desktop-style/Makefile
  head/x11-themes/lumina-themes/Makefile
  head/x11-themes/lxqt-themes/Makefile
  head/x11-themes/plasma5-breeze/Makefile
  head/x11-themes/plasma5-breeze-gtk/Makefile
  head/x11-themes/plasma5-kde-gtk-config/Makefile
  head/x11-themes/plasma5-oxygen/Makefile
  head/x11-themes/plasma5-plasma-workspace-wallpapers/Makefile
  head/x11-themes/qt5-style-plugins/Makefile
  head/x11-themes/qtcurve/Makefile
  head/x11-themes/qtcurve-kf5/Makefile
  head/x11-themes/qtcurve-qt5/Makefile
  head/x11-themes/xfce-evolution/Makefile
  head/x11-toolkits/ctk/Makefile
  head/x11-toolkits/kf5-attica/Makefile
  head/x11-toolkits/kf5-kcompletion/Makefile
  head/x11-toolkits/kf5-kconfigwidgets/Makefile
  head/x11-toolkits/kf5-kdesignerplugin/Makefile
  head/x11-toolkits/kf5-kguiaddons/Makefile
  head/x11-toolkits/kf5-kirigami2/Makefile
  head/x11-toolkits/kf5-kitemviews/Makefile
  head/x11-toolkits/kf5-kjobwidgets/Makefile
  head/x11-toolkits/kf5-ktextwidgets/Makefile
  head/x11-toolkits/kf5-kwidgetsaddons/Makefile
  head/x11-toolkits/kf5-kxmlgui/Makefile
  head/x11-toolkits/kproperty/Makefile
  head/x11-toolkits/plasma5-kdeplasma-addons/Makefile
  head/x11-toolkits/py-qt5-gui/Makefile
  head/x11-toolkits/py-qt5-quick/Makefile
  head/x11-toolkits/py-qt5-quickwidgets/Makefile
  head/x11-toolkits/py-qt5-widgets/Makefile
  head/x11-toolkits/qml-box2d/Makefile
  head/x11-toolkits/qt5-canvas3d/Makefile
  head/x11-toolkits/qt5-charts/Makefile
  head/x11-toolkits/qt5-datavis3d/Makefile
  head/x11-toolkits/qt5-declarative/Makefile
  head/x11-toolkits/qt5-gamepad/Makefile
  head/x11-toolkits/qt5-gtkplatform/Makefile
  head/x11-toolkits/qt5-gui/Makefile
  head/x11-toolkits/qt5-quickcontrols/Makefile
  head/x11-toolkits/qt5-quickcontrols2/Makefile
  head/x11-toolkits/qt5-uiplugin/Makefile
  head/x11-toolkits/qt5-virtualkeyboard/Makefile
  head/x11-toolkits/qt5-widgets/Makefile
  head/x11-toolkits/qt5pas/Makefile
  head/x11-toolkits/qtermwidget/Makefile
  head/x11-toolkits/qtermwidget-l10n/Makefile
  head/x11-toolkits/qwt5-qt5/Makefile
  head/x11-toolkits/qwt6/Makefile
  head/x11-wm/lxqt-panel/Makefile
  head/x11-wm/obconf-qt/Makefile
  head/x11-wm/plasma5-kdecoration/Makefile
  head/x11-wm/plasma5-kwin/Makefile