Bug 234127 - misc/freebsd-doc-de: pnmtopng: bad magic number 0x2d67
Summary: misc/freebsd-doc-de: pnmtopng: bad magic number 0x2d67
Status: Closed DUPLICATE of bug 234126
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Document Engineering Group (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-18 09:57 UTC by O. Hartmann
Modified: 2020-04-22 18:15 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (doceng)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-12-18 09:57:12 UTC
See also Bug 234126 for a description. The error is almost the same as reported in the previously mentioned bug report:

/usr/local/bin/perl /usr/ports/misc/freebsd-doc-de/work/doc/share/misc/epsgeom -offset 100 100 /usr/ports/misc/freebsd-doc-de/work/doc/de_DE.ISO8859-1/books/handbook/../../../share/images/books/handbook/advanced-networking/net-routing.eps  | /usr/local/bin/gs -q -dBATCH -dGraphicsAlphaBits=4 -dTextAlphaBits=4  -dEPSCrop -r100x100  -dNOPAUSE -dSAFER -sDEVICE=pnm -sOutputFile=-  -g`/usr/local/bin/perl /usr/ports/misc/freebsd-doc-de/work/doc/share/misc/epsgeom -geom 100 100 /usr/ports/misc/freebsd-doc-de/work/doc/de_DE.ISO8859-1/books/handbook/../../../share/images/books/handbook/advanced-networking/net-routing.eps` -  | /usr/local/bin/pnmtopng > /usr/ports/misc/freebsd-doc-de/work/doc/de_DE.ISO8859-1/books/handbook/../../../share/images/books/handbook/advanced-networking/net-routing.png
Error: no BoundingBox found: /usr/ports/misc/freebsd-doc-de/work/doc/de_DE.ISO8859-1/books/handbook/../../../share/images/books/handbook/advanced-networking/net-routing.eps
Error: no BoundingBox found: /usr/ports/misc/freebsd-doc-de/work/doc/de_DE.ISO8859-1/books/handbook/../../../share/images/books/handbook/advanced-networking/net-routing.eps
pnmtopng: bad magic number 0x2d67 - not a PPM, PGM, PBM, or PAM file
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/misc/freebsd-doc-de/work/doc/de_DE.ISO8859-1/books/handbook
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/misc/freebsd-doc-de/work/doc/de_DE.ISO8859-1/books
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/misc/freebsd-doc-de/work/doc/de_DE.ISO8859-1
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/misc/freebsd-doc-de/work/doc
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/misc/freebsd-doc-de
*** Error code 1

Stop.
make: stopped in /usr/ports/misc/freebsd-doc-de

===>>> make build failed for misc/freebsd-doc-de
===>>> Aborting update
Comment 1 Matthias Andree freebsd_committer 2020-04-22 17:50:18 UTC

*** This bug has been marked as a duplicate of bug 234126 ***
Comment 2 commit-hook freebsd_committer 2020-04-22 18:15:13 UTC
A commit references this bug:

Author: mandree
Date: Wed Apr 22 18:14:26 UTC 2020
New revision: 532494
URL: https://svnweb.freebsd.org/changeset/ports/532494

Log:
  Fix docs build that is broken on some systems.

  Apparently, changes in the docproj toolchain sensitivized ps2epsi.ps
  (ghostscript) against paper size mismatches in some circumstances.
  Set the paper size consistently to A4 for PIC2PS (groff), PS2EPS (gs),
  PS2BBOX (also gs). [1]

  While here, blank DISPLAY so that the textproc/fop tool can make progress
  if the DISPLAY isn't working (stalled ssh forward, xauth broken, whatever).

  Remove MAKE_JOBS_UNSAFE, this was brought in in an attempt to fix the
  build issues which turned out to be blank gs (Ghostscript) output rather
  than broken dependencies in the Makefiles.

  PR:		234126
  PR:		234127 (duplicate of 234126)
  Submitted by:	fluffy@FreeBSD.org [1]
  Reported by:	ohartmann@walstatt.org
  Reviewed by:	driesm.michiels@gmail.com
  Approved by:	maintainer timeout (doceng@, 15 days)

Changes:
  head/misc/freebsd-doc-en/Makefile
  head/misc/freebsd-doc-en/files/
  head/misc/freebsd-doc-en/files/patch-share_mk_doc.commands.mk