Bug 234132 - x11/kde5: System settings crashes, minimise window artifacts
Summary: x11/kde5: System settings crashes, minimise window artifacts
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords: crash, needs-qa
Depends on:
Blocks:
 
Reported: 2018-12-18 12:28 UTC by bourne.identity@hotmail.com
Modified: 2019-10-17 15:03 UTC (History)
4 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments
Sample of flashing and streaking when panel buttons are clicked in KDE5 (416.41 KB, video/mp4)
2018-12-18 12:40 UTC, bourne.identity@hotmail.com
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bourne.identity@hotmail.com 2018-12-18 12:28:02 UTC
I installed xorg + drm-kmod + kde5 on a 12.0 box (amd64 with Radeon-CAICOS dedicated graphics card; radeonkms always loaded). The installation was clean. 

But on start of operations, I ran into multiple problems:

1) Clicking panel buttons for minimized windows leads to a strange flashing and streaking, instead of the window being restored. See the attachment desktop.m4v for a sample of 5 clicks on the Thunderbird button in the panel.

2) System settings launched a few times initially. But after the flashing and streaking became too bothersome, System Settings started crashing. I could never start System Settings applet yesterday - each time I was met with "This program has crashed unexpectedly".

I would like to request two things :

1) More testing of KDE5

2) Making KDE4 packages available for 12.0 Release till KDE5 starts working well. This request has also been made in Bug# 234129 filed for build failure of KDE4 (from ports) under FreeBSD 12.0.


Thanks.
Manish Jain
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2018-12-18 12:38:06 UTC
Bugzilla is for tracking issues that can be reproduced, isolated, and that can have a proposed change (most often, a commit) associated with them. 

This precludes the second (1), "ask for more testing", and (2), as it has already been reported in a separate bug. Having said that, feedback/suggestions are welcome, so thank you for providing that.

This leaves the first (1) and (2), namely:

- Streaking and flashing when minimising windows
- Crashing

Regarding the crash, could you please:

- Build the kde stack with debug enabled (at least make.conf: WITH_DEBUG)
- Provide a traceback for the crash as an attachment.

Without steps to reproduce or a method to isolate the issue further, it will be difficult at best to resolve these issues.
Comment 2 bourne.identity@hotmail.com 2018-12-18 12:40:52 UTC
Created attachment 200226 [details]
Sample of flashing and streaking when panel buttons are clicked in KDE5
Comment 3 bourne.identity@hotmail.com 2018-12-18 12:45:52 UTC
Hi Kubilay,

Thanks for taking the lead on this bug report.

I do not know whether I can try reinstalling KDE5 all over again with debug enabled this time - that would need a whole lot of time, perhaps many days.

So I request KDE4 packages be made available for 12.0 Release too. That I think should solve the situation for the interim.


Thanks.
Manish Jain
Comment 4 Tobias C. Berner freebsd_committer 2018-12-18 19:07:49 UTC
Hi Manish

Thanks for the report.

The graphical glitches sound driver related. (Earlier versions of the i915 had redraw glitches too). I would check with the x11/graphic stack maintainers for this. 

I'm using Plasma5 myself on nvidia and multiple i915 devices, but do not have any Radeon device to test. 


It would be helpful if you could gather backtraces and also log the plasma session output. 



Mfg Tobias
Comment 5 bourne.identity@hotmail.com 2018-12-18 19:50:35 UTC
Hi Tobias,

I am willing to work on this under your eye - I reinstall K5 and then gather the necessary backtrace.

It would help if you could put the backtrace generation into a shell script that I can run easily.


Thanks.
Manish.
Comment 6 bourne.identity@hotmail.com 2018-12-19 09:48:06 UTC
Hi Tobias/Kubilay,

Since I shall be running the debug version, I assume you want me to build the kde5 port, and not install the kde5 package.

Is that right ?

Is it enough for me to set WITH_DEBUG=yes in /etc/make.conf and then build the kde5 port ?

Thanks.
MJ
Comment 7 Adriaan de Groot freebsd_committer 2018-12-19 16:51:53 UTC
1) Does the flashing / tearing problem also exist if you run Plasma 5 desktop as a different user, with the default theme, layout, settings, .. ? (Create a new user, then log in with a Plasma session from SDDM)

2) For backtraces, you might get away with starting systemsettings in gdb in a terminal window, e.g. in konsole run "gdb $(which systemsettings5)". If it crashes, enter command "bt" or "bt all" and copy-paste the stack trace into an attachment. To rebuild with debug, you'll want to set it in make.conf and then rebuild all that's necessary: I'd suggest qt5\* (except for qt5-webengine, since that's not going to work with debugging enabled), kf5\*, and plasma5\* .

What's a CAICOS? I have some random AMD card lying around here -- looks like an R7 360 to me. I could try swapping some stuff around, but if your hardware is something way off then there's not much point.
Comment 8 bourne.identity@hotmail.com 2018-12-19 17:11:30 UTC
Hi Adrian/others,

#1

<<<
Does the flashing / tearing problem also exist if you run Plasma 5 desktop as a different ...
>>>

I doubt that. For about a day, the flashing/tearing was not visible/apparent enough, and the System settings applet too worked well. It was only after a day of use that window restoration from panel became a spectacle. When I thought this might be something related to Desktop Effects, I tried turning DE off. But then the System Settings applet went bonkers too.

#2

I shall be running K5 again only after setting up the debug environment - I have never launched a debug environment like this before. So I shall need clear instruction.

a)
Should I reinstall FreeBSD ? The current installation was without kernel-dbg
distribution.

b)
On a clean box, I put 'WITH_DEBUG=yes' in /etc/make.conf and then build xorg and kde5. Is that what I should do to get the backtrace setup ready ?

CAICOS is R5 230 (My OEM is Sapphire Radeon). Actually it comes as a nasty solution to me that I could ship out the Radeon card and put in an NVidia card. A not-so-ingenuous solution, but a solution none the less that I will keep in the back of my mind.

Thanks.
Manish Jain
Comment 9 Adriaan de Groot freebsd_committer 2018-12-25 15:27:30 UTC
This was reported independently (graphics glitches) on the mailing list, followed by:

> As of Dec 24 11:55:52  pkg[18901]: xf86-video-intel upgraded: 2.99.917.20180906 -> 2.99.917.20181203 the problem is resolved.
Comment 10 Adriaan de Groot freebsd_committer 2018-12-25 15:33:03 UTC
> On a clean box, I put 'WITH_DEBUG=yes' in /etc/make.conf and then build xorg and kde5. Is that what I should do to get the backtrace setup ready ?

That is sufficient, yes. If systemsettings keeps crashing, then start it from the command-line (e.g. from a konsole window inside your Plasma session):

```
$ gdb $( which systemsettings5 )
(gdb) run
```

and if it crashes, get a backtrace.
Comment 11 bourne.identity@hotmail.com 2018-12-25 15:42:09 UTC
I installed Lumina in the meanwhile, and I am quite happy with it.

But if I were to install kde5 now from pkg, can I be reasonably certain/hopeful that the glitch has gone ? Else I will keep in mind to install from ports.

More importantly, I need some info to update a port (mkdesktop) that I own.
I need info on the pkg's and kld's needed by various graphics chips.

As per my (incomplete) knowledge, the following are usually needed:

Chipset   |	<Packages>		| <Modules>

AMD GPU	  | drm-kmod:xf86-video-amdgpu	|
Radeon	  | drm-kmod:xf86-video-ati	| radeonkms.ko**
NVidia	  | drm-kmod:nvidia-driver  	| nvidia.ko:nvidia-modeset.ko
Intel GPU | drm-kmod:xf86-video-intel	|

(** : 12.0 needs just radeonkms; 11.x needs radeon+radeonkms)

Is the above table correct and complete ?
If not, can someone please fill in the missing bits ?


Thanks.
Manish Jain
Comment 12 bourne.identity@hotmail.com 2018-12-27 10:27:35 UTC
Adriaan/Tobias/Kubilay,

I installed KDE5 2 days back and have been using it continuously. The flashing/tearing problem does not show up, and System Settings works cleanly too.

I am quite sure the glitches have been taken care of, and I really like KDE5 all the more for your dedicated effort.

I am leaving the status as it is, for one of you to close the PR as fixed.


Thanks all.
Manish Jain
Comment 13 bourne.identity@hotmail.com 2018-12-27 10:42:02 UTC
Just as soon as I posted the previous message, the window flashing/tearing upon restore from iconified state has popped up  : - )

So the PR should perhaps remain open. System Settings still starts up though.

Thanks.
Manish Jain
Comment 14 Tobias C. Berner freebsd_committer 2019-03-30 20:23:33 UTC
Moin moin

Is this still an issue with the newest drm drivers?


mfg Tobias