Bug 234171 - graphics/drm-kmod: just activates one screen on 12.0 instead of both screens as on 11.2 (see local kernel hacker)
Summary: graphics/drm-kmod: just activates one screen on 12.0 instead of both screens ...
Status: Closed Not Accepted
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Johannes M Dieterich
URL:
Keywords: needs-patch, regression
Depends on:
Blocks:
 
Reported: 2018-12-19 17:39 UTC by georg-bsd
Modified: 2018-12-28 11:41 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (jmd)


Attachments
Screenshot "See your local kernel hacker" (509.93 KB, image/jpeg)
2018-12-19 17:39 UTC, georg-bsd
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description georg-bsd 2018-12-19 17:39:08 UTC
Created attachment 200276 [details]
Screenshot "See your local kernel hacker"

I got an AMD Radeon Pitcarain GPU. It runs smoothly on 11.2-RELEASE with dual monitor. As i upgraded to freebsd 12.0-RELEASE it shows just one monitor. As i read on the notes that there is amdgpu driver for newer cards HD7000+. 

The radeonkms driver on 12.0 just activates one screen instead of both screens as on 11.2-RELEASE.

I took this screenshot (as i dont have a local kernel hacker)
Comment 1 georg-bsd 2018-12-19 17:41:17 UTC
I installed drm-kmod. Thats the reason why i choosed "ports & packages"
Comment 2 Lorenzo Salvadore 2018-12-19 20:40:32 UTC
The following bug might be relatated to this one: bug #234044.
Comment 3 Johannes M Dieterich freebsd_committer 2018-12-26 21:31:07 UTC
This is not a problem with the port itself but with the actual DRM. Please report this upstream (i.e., https://github.com/FreeBSDDesktop/kms-drm ) which is where these issues are being tracked and where they are being worked on and fixed. Thanks.
Comment 4 georg-bsd 2018-12-28 11:41:17 UTC
I opened a issue on github

https://github.com/FreeBSDDesktop/kms-drm/issues/116