Bug 234173 - security/amavisd-new: Fix Perl 5.28 warning about unescaped brace
Summary: security/amavisd-new: Fix Perl 5.28 warning about unescaped brace
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Florian Smeets
URL:
Keywords: easy
Depends on:
Blocks:
 
Reported: 2018-12-19 18:33 UTC by Mark.Martinec
Modified: 2019-01-14 22:09 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (flo)


Attachments
Add a missing backslash-escape to left brace in a regexp, fixes warning (463 bytes, patch)
2018-12-19 18:33 UTC, Mark.Martinec
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark.Martinec 2018-12-19 18:33:35 UTC
Created attachment 200278 [details]
Add a missing backslash-escape to left brace in a regexp, fixes warning

Perl 5.28 introduced a warning about unescaped left brace in a regexp,
resulting in a warning issued during amavisd startup:

  Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.32), passed through in regex; marked by <-- HERE in m/ ( { <-- HERE } (?: / \* )? | \* ) / at (eval 112) line 830.

Currently the warning is harmless although annoying, but will become a fatal error
with the next version of perl.

The attached patch adds the missing backslash-escape, please apply.
Comment 1 commit-hook freebsd_committer 2019-01-14 22:08:55 UTC
A commit references this bug:

Author: flo
Date: Mon Jan 14 22:08:46 UTC 2019
New revision: 490317
URL: https://svnweb.freebsd.org/changeset/ports/490317

Log:
  Add a missing backslash-escape to left brace in a regexp

  Perl 5.28 introduced a warning about unescaped left brace in a regexp,
  resulting in a warning issued during amavisd startup:

  Unescaped left brace in regex is deprecated here (and will be fatal in Perl
  5.32), passed through in regex; marked by <-- HERE in m/ ( { <-- HERE }
  (?: / \* )? | \* ) / at (eval 112) line 830.

  Currently the warning is harmless although annoying, but will become a fatal error
  with the next version of perl.

  PR:		234173
  Submitted by:	Mark.Martinec@ijs.si

Changes:
  head/security/amavisd-new/Makefile
  head/security/amavisd-new/files/patch-amavisd
Comment 2 Florian Smeets freebsd_committer 2019-01-14 22:09:24 UTC
Committed. Thanks.