Bug 234288 - devel/trio broken
Summary: devel/trio broken
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rodrigo Osorio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-23 03:28 UTC by Mikhail Teterin
Modified: 2018-12-28 14:10 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (rodrigo)


Attachments
Improve devel/trio (4.43 KB, patch)
2018-12-23 03:28 UTC, Mikhail Teterin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Teterin freebsd_committer 2018-12-23 03:28:29 UTC
Created attachment 200384 [details]
Improve devel/trio

The current version of the port has a number of problems:

1) The shared library is misnamed (libtrio.so.2.0.0)
2) There is no shlib symlink installed, so ports LIB_DEPENDing on trio (such as  graphics/GraphicsMagick) break
3) The shared library is created EMPTY - none of the compiled shared objects are put into it
4) The static library is built from files compiled with position-independent mode (-fPIC), needlessly.
5) The upstream's documentation is installed, which adds no value - the texts are available online.
6) The bundled test-suit is not used.

The proposed patch changes things thus:

1) Build and install the library using the bsd.lib.mk
2) Compile and run the author's regression.c
3) Patch the regression.c to work - not sure, why the patch is needed
4) Do not bother with the docs - these aren't man-pages and require a browser anyway, may as well read them online.
Comment 1 commit-hook freebsd_committer 2018-12-28 14:04:12 UTC
A commit references this bug:

Author: rodrigo
Date: Fri Dec 28 14:03:34 UTC 2018
New revision: 488600
URL: https://svnweb.freebsd.org/changeset/ports/488600

Log:
  Fix multiple issues in devel/trio

   * unbreak the port in the tier architectures
   * add a bsd makefile to build and install the port instead of a gnu makefile
   * run the author regression test as part of the build process
   * do the proper changes to be able to disable the documentation

  The new generated lib is named libtrio.so.2 ( previously misnamed libtrio.so.2.0.0)
  and the libtrio.so symlink is generated.  An entry in the UPDATING file was added
  about those changes

  Bump portrevision.

  PR:		234288
  Submitted by:	mi

Changes:
  head/UPDATING
  head/devel/trio/Makefile
  head/devel/trio/files/BSDmakefile
  head/devel/trio/files/patch-Makefile.in
  head/devel/trio/files/patch-regression.c
  head/devel/trio/pkg-plist
Comment 2 Rodrigo Osorio freebsd_committer 2018-12-28 14:06:33 UTC
committed thanks.

I didn't remove the documentation because I think it's useful to have it and has size cost is so small.
Comment 3 Mikhail T. 2018-12-28 14:10:57 UTC
Thanks. You may wish to also reach out to the author regarding our need to patch the regression.c