Bug 234298 - audio/easytag: fix build with GCC-based architectures
Summary: audio/easytag: fix build with GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Roman Bogorodskiy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-23 14:46 UTC by Piotr Kubaj
Modified: 2018-12-26 11:49 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (novel)


Attachments
patch (721 bytes, patch)
2018-12-23 14:46 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2018-12-23 14:46:45 UTC
Created attachment 200396 [details]
patch

This port requires USES=compiler:c++11-lang to build on GCC architectures.

While here, add USES=gnome localbase.

Tested on powerpc64 and amd64.

Hardware sponsored by IntegriCloud.
Comment 1 Roman Bogorodskiy freebsd_committer 2018-12-25 16:28:34 UTC
(In reply to Piotr Kubaj from comment #0)

Thanks for the fix!

I was curious to see the error causing build failure, but I wasn't able to reproduce that on armv6 and aarch64. I'll try to check on my physical powerpc box, but it will take some time (it's slow).

In the meantime, could you please the build failure log if you still have one?
Comment 2 Piotr Kubaj freebsd_committer 2018-12-25 16:44:44 UTC
(In reply to Roman Bogorodskiy from comment #1)
https://talos.anongoth.pl/data/powerpc64-default/2018-12-18_10h57m00s/logs/errors/easytag-2.4.3_1.log

It wants to link to /usr/local/lib/libtag.so, which is compiled with ports GCC, which uses new GCC ABI.
Comment 3 commit-hook freebsd_committer 2018-12-26 11:49:32 UTC
A commit references this bug:

Author: linimon
Date: Wed Dec 26 11:49:05 UTC 2018
New revision: 488369
URL: https://svnweb.freebsd.org/changeset/ports/488369

Log:
  This port requires USES=compiler:c++11-lang to build on GCC-based
  architectures because it wants to link to /usr/local/lib/libtag.so,
  which is compiled with ports GCC, which uses new GCC ABI.

  While here, add USES=gnome localbase and pet portlint.

  PR:		234298
  Submitted by:	Piotr Kubaj
  Approved by:	portmgr (tier-2 blanket)

Changes:
  head/audio/easytag/Makefile